Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154958 - wxGTK is not building properly with gcc4
Summary: wxGTK is not building properly with gcc4
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: wxGTK
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 155142 (view as bug list)
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-04-15 03:13 UTC by Tom "spot" Callaway
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-22 20:24:18 UTC


Attachments (Terms of Use)
GCC4 patch for wxGTK (deleted)
2005-04-15 18:35 UTC, Ignacio Vazquez-Abrams
no flags Details | Diff
Another patch for gcc4 (deleted)
2005-04-16 23:54 UTC, Denis Leroy
no flags Details | Diff

Description Tom "spot" Callaway 2005-04-15 03:13:28 UTC
Description of problem:

wxGTK is not being built properly with gcc4. This is causing all packages which
use wxGTK libs to get errors like the following (from comical):

/usr/lib/gcc/i386-redhat-linux/4.0.0/../../../libwx_gtk2-2.4.so: undefined
reference to `wxwxListStringNode::~wxwxListStringNode()'
/usr/lib/gcc/i386-redhat-linux/4.0.0/../../../libwx_gtk2-2.4.so: undefined
reference to `wxwxMenuItemListNode::~wxwxMenuItemListNode()'
/usr/lib/gcc/i386-redhat-linux/4.0.0/../../../libwx_gtk2-2.4.so: undefined
reference to `wxwxMenuItemListNode::~wxwxMenuItemListNode()'
/usr/lib/gcc/i386-redhat-linux/4.0.0/../../../libwx_gtk2-2.4.so: undefined
reference to `vtable for wxFileProto'
/usr/lib/gcc/i386-redhat-linux/4.0.0/../../../libwx_gtk2-2.4.so: undefined
reference to `wxwxListStringNode::~wxwxListStringNode()'

This is pretty serious, as its failing other builds which would otherwise succeed.

Comment 1 Ignacio Vazquez-Abrams 2005-04-15 11:04:22 UTC
Hooray for classes created by macros :/

Anyways, I'm working on a patch for this and other warnings against gcc4. The
offending code is a macro in include/list.h.

Comment 2 Ignacio Vazquez-Abrams 2005-04-15 18:35:30 UTC
Created attachment 113243 [details]
GCC4 patch for wxGTK

Give this a spin. It cleans up most warnings.

Comment 3 Tom "spot" Callaway 2005-04-16 14:29:49 UTC
With Ignacio's patch, we are almost there... but we still throw one error:

/usr/lib/gcc/i386-redhat-linux/4.0.0/../../../libwx_gtk2-2.4.so: undefined
reference to `vtable for wxFileProto'



Comment 4 Denis Leroy 2005-04-16 23:54:20 UTC
Created attachment 113274 [details]
Another patch for gcc4

Fixes an incorrect #pragma implementation line. the wxFileProto problem seems
to be ok now.

Comment 5 Tom "spot" Callaway 2005-04-17 04:49:35 UTC
Confirmed, with these two patches, wxGTK2 builds libraries that comical can link
to without error. Mr. Maintainer, please commit these patches, schedule a wxGTK
rebuild, and close this bug. :)

Thanks to Denis and Ignacio.

Comment 6 Dams 2005-04-17 07:57:21 UTC
*** Bug 155142 has been marked as a duplicate of this bug. ***

Comment 7 Warren Togami 2005-04-19 05:30:51 UTC
Anvil did you push this?

Comment 8 Dams 2005-04-20 18:37:41 UTC
Not yet, unfortunately.. i'm unable to connect the cvs. Dunno what i have
broken. I will try to catch sopwith to help me to fix it.. 
Warren, could you commit it please ? Sorry people.

Comment 9 Dams 2005-04-22 20:24:18 UTC
Voila, it's applied in CVS. Thanks people.
It's been requested for rebuild for FE4.


Note You need to log in before you can comment on or make changes to this bug.