Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154954 - Adding user to a group changes primary group
Summary: Adding user to a group changes primary group
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-users
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact:
URL:
Whiteboard:
: 157633 (view as bug list)
Depends On:
Blocks: 156320
TreeView+ depends on / blocked
 
Reported: 2005-04-15 00:48 UTC by David Lehman
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version: RHBA-2005-672
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-28 20:03:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:672 qe-ready SHIPPED_LIVE redhat-config-users bug fix update 2005-09-28 04:00:00 UTC

Description David Lehman 2005-04-15 00:48:38 UTC
+++ This bug was initially created as a clone of Bug #111199 +++

Adding a user to a group from the UI accessed with double-clicking a
user, then opening the Groups tab causes the selected choice in the
Primary Group drop-down box to change, apparently to the
alphabetically first group the user is a member of.  This results
easily in accidental primary group changes for users.


Name and version of package:
redhat-config-users-1.1.18-2


To reproduce:
1. add a user to a group which alphabetically comes before the user's primary group
2. double click on that user in r-c-users and select groups tab
3. check the box net to an unchecked group in the list


Actual results:
primary group is changed to whichever of the user's groups is first alphabetically


Expected results:
no change to primary group pulldown


Additional Information:
I'll be happy to post a patch here if you want, but the patch is already in
s-c-users in RHEL4. It's the tempName stuff in method toggled_item in
userProperties.py.

Comment 1 Bastien Nocera 2005-05-13 12:32:04 UTC
*** Bug 157633 has been marked as a duplicate of this bug. ***

Comment 10 Red Hat Bugzilla 2005-09-28 20:03:58 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-672.html



Note You need to log in before you can comment on or make changes to this bug.