Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154947 - saslauthd doesn't start early enough
Summary: saslauthd doesn't start early enough
Keywords:
Status: CLOSED DUPLICATE of bug 154943
Alias: None
Product: Fedora
Classification: Fedora
Component: cyrus-sasl
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-14 23:05 UTC by Nathan G. Grennan
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-13 09:04:55 UTC


Attachments (Terms of Use)

Description Nathan G. Grennan 2005-04-14 23:05:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050322 Galeon/1.3.20

Description of problem:
saslauthd is used by postfix and other mail software like cyrus-imapd for authencation. By default saslauthd starts at 95, while postfix starts at 80, and cyrus-imapd starts at 65. This creates a time window where postfix and cyrus-imapd have started, but saslauthd hasn't. So a user tries to authenicate, but fails because saslauthd isn't avaliable. In my case I also use mysql to store mail user authencation information. mysql starts at 64, and needs be to be running before saslauthd. So I have changed /etc/rc.d/init.d/saslauthd so that it starts at 64 instead of 95. Ideally we would want enough time delay bewteen mysql and saslauthd so that mysql has time to initialize. The same is true for saslauthd and cyrus-imapd.

Ideally if mysqld, postgresql, openldap, and anything else that might use be used by saslauthd could be kept before saslauthd, along with moving saslauthd before anything that might use it like postfix and cyrus-imapd.

Version-Release number of selected component (if applicable):
cyrus-sasl-2.1.20-4

How reproducible:
Always

Steps to Reproduce:
1. Install saslauthd, mysqld, and postfix
2. chkconfig saslauthd on ; chkconfig mysqld on ; chkconfig postfix on
3. ls -al /etc/rc.d/rc3.d

Actual Results:  S64mysqld -> ../init.d/mysqld
S80postfix -> ../init.d/postfix
S95saslauthd -> ../init.d/saslauthd

Expected Results:  S64mysqld -> ../init.d/mysqld
S64saslauthd -> ../init.d/saslauthd
S80postfix -> ../init.d/postfix

Additional info:

Comment 1 Marius Andreiana 2005-05-13 09:04:55 UTC

*** This bug has been marked as a duplicate of 154943 ***


Note You need to log in before you can comment on or make changes to this bug.