Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154946 - coreutils - su pam bugs
Summary: coreutils - su pam bugs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: coreutils
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 156322
TreeView+ depends on / blocked
 
Reported: 2005-04-14 22:55 UTC by Steve Grubb
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: RHBA-2005-540
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-05 14:38:00 UTC


Attachments (Terms of Use)
patch fixing problems described herein (deleted)
2005-04-14 22:59 UTC, Steve Grubb
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:540 qe-ready SHIPPED_LIVE coreutils bug fix update 2005-10-05 04:00:00 UTC

Description Steve Grubb 2005-04-14 22:55:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050227 Firefox/1.0.1 Fedora/1.0.1-2

Description of problem:
The first issue is that su does not set the pam tty variable. This is needed 
for auditing among other things.

Next, if there was a problem with init groups, session close must be called 
since session open can mount drives.

The pam credentials should not be set in the child since the parent will need 
to dispose of credentials later.

If there is a fork error, pam credentials need to be deleted and the session 
closed.

The parent needs to delete the pam credentials before it ends pam.

Version-Release number of selected component (if applicable):
coreutils-5.2.1-44

How reproducible:
Always

Steps to Reproduce:
1. install the latest pam
2. do a su - root
3. look in the audit log what tty

the other items are based on code review  

Actual Results:  terminal=?

Expected Results:  terminal=pts/5

Additional info:

Comment 1 Steve Grubb 2005-04-14 22:59:11 UTC
Created attachment 113197 [details]
patch fixing problems described herein

Comment 2 Tim Waugh 2005-04-15 16:46:51 UTC
Thanks.  Fixed in CVS.

Comment 3 Red Hat Bugzilla 2005-10-05 14:38:00 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-540.html



Note You need to log in before you can comment on or make changes to this bug.