Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154945 - Kxkb doesn't support Korean keyboards
Summary: Kxkb doesn't support Korean keyboards
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-14 22:41 UTC by Dimitri Papadopoulos
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-15 22:30:09 UTC


Attachments (Terms of Use)
error message in Kxkb tray icon (deleted)
2005-04-14 22:44 UTC, Dimitri Papadopoulos
no flags Details
configuration panel of Kxkb (deleted)
2005-04-14 22:48 UTC, Dimitri Papadopoulos
no flags Details

Description Dimitri Papadopoulos 2005-04-14 22:41:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Fedora/1.7.6-1.3.2

Description of problem:
Kxkb doesn't support Korean keyboards. It's effectively impossible to input Korean under KDE.

I've configured Kxkb to support Greek, French, and Korean. Switching to Greek and French keayboard mappings works: I'm able to input Greek and French. However switching to Korean doesn't work: the Kxkb tray icon displays a redd "err" message instead of "ko" as expected.

Version-Release number of selected component (if applicable):
kdebase-3.3.1-4.3.FC3

How reproducible:
Always

Steps to Reproduce:
1. Have Kxkb activated and running. 
2. Configure it to support Korean and another language. 
3. Switch to Korean by clicking on the tray icon.
4. The tray icon displays "err" and the previous keyboard mapping is used instead.


Actual Results:  The tray icon displays "err" and one can't input Korean.


Expected Results:  The tray icon displays "ko" and I can input Korean.


Additional info:

See also bug #112024.

I had requested a Korean keyboard mapping. The fix was apprently to introduce a Korean keyboard mapping. I guess the current error is a consequence of that fix. 

FYI, here is my context:
I understand there's more than keyboard mappings to Korean, and that I'd need some input method to be able to input Korean. My final goal is indeed to be able to input Korean under KDE. This does not seem to be possible - under a non-Korean locale at least. I wonder what is the reason for that? Is KDE totally broken with respect to i18n? Doesn't Fedora install KDE properly? Does it miss patches (I think KDE+i18n work much better on Mandrakelinux for example)?

Comment 1 Dimitri Papadopoulos 2005-04-14 22:44:49 UTC
Created attachment 113195 [details]
error message in Kxkb tray icon

Comment 2 Dimitri Papadopoulos 2005-04-14 22:48:12 UTC
Created attachment 113196 [details]
configuration panel of Kxkb

Greek, French and Korean mappings are selected.
The current locale is fr_FR.UTF-8.

Comment 3 A. Folger 2006-02-06 21:57:21 UTC
I just upgraded to kde 3.5.1 on fc4-with-all-updates, and my Swiss-German layout
isn´t available anymore.

Comment 4 Ngo Than 2006-02-15 22:30:09 UTC
i will push new kdebase into FC4 update this week, it should fix this problem.
Thanks for your report


Note You need to log in before you can comment on or make changes to this bug.