Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154941 - mkinitrd fails to find scsi modules in modules.conf
Summary: mkinitrd fails to find scsi modules in modules.conf
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: mkinitrd
Version: 3.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Peter Jones
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-14 22:00 UTC by David Huffman
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-19 19:04:35 UTC


Attachments (Terms of Use)

Description David Huffman 2005-04-14 22:00:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
mkinitrd fails to find scsi modules in modules.conf if using probeall instead of alias. The mkinitrd script greps for alias but does not look for probeall:

scsimodules=`grep "alias[[:space:]]\+scsi_hostadapter" $modulefile | grep -v '^[    ]*#' | LC_ALL=C sort -u | awk '{
print $3 }'`

Recommend mkinitrd look for both alias and probeall entries (as modprobe does) to determine which scsi host adapter modules to load in the initrd.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.enter "probeall scsi_hostadapter cciss" in modules.conf
2.run mkinitrd
3.reboot using new initrd
4.kernel panic unable to locate the rootfs
5.enter "alias scsi_hostadapter cciss" in modules.conf
6.run kninitrd
7.reboot using new initrd
8.no kernel panic
  

Additional info:

This occurs when updating the kernel and running the mkinitrd command. Since this causes the system to no longer boot, I will note this as high priority.

Comment 1 Peter Jones 2005-04-19 21:22:26 UTC
This isn't the supported way of doing this.

If you need two modules loaded, do (using aha7xxx as an example since I don't
know what you've got):

alias scsi_hostadapter0 ata7xxx
alias scsi_hostadapter1 cciss

And both mkinitrd and rc.sysinit will handle them correctly.

Comment 2 David Huffman 2005-08-24 20:20:10 UTC
Although this may not be the way Red Hat creates their modules.conf files, it 
is still valid to use probeall in the modules.conf file and is valid for the 
modprobe command. I am surely not the only user that has made VALID manual 
updates to the modules.conf file. I do not feel this is an unreasonable 
request for the mkinitrd command to properly handle valid uses of both alias 
and probeall in the modprobe.conf file. 

Comment 3 Peter Jones 2006-02-28 15:36:07 UTC

*** This bug has been marked as a duplicate of 182008 ***

Comment 4 David Huffman 2006-02-28 17:49:12 UTC
This is not a duplicate of 182008. This is a separate issue. 

Comment 5 Red Hat Bugzilla 2007-02-05 19:34:43 UTC
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.

Comment 6 RHEL Product and Program Management 2007-10-19 19:04:35 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.