Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154933 - kernel: hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
Summary: kernel: hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alan Cox
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-14 21:23 UTC by Mace Moneta
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-30 00:21:29 UTC


Attachments (Terms of Use)

Description Mace Moneta 2005-04-14 21:23:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
After upgrading to kernel-2.6.11-1.14_FC3 from kernel-2.6.10-1.770_FC3, I'm periodically seeing messages about my CD drive (note, the drive is just idle when these occur):

Apr 14 16:26:34 mmouse kernel:     ide2: BM-DMA at 0x9800-0x9807, BIOS settings: hde:pio, hdf:pio
Apr 14 16:26:34 mmouse kernel: hde: CD-RW BCE5224IM, ATAPI CD/DVD-ROM drive
Apr 14 16:26:36 mmouse kernel: hde: ATAPI 52X CD-ROM CD-R/RW drive, 2048kB Cache
Apr 14 16:27:09 mmouse fstab-sync[4838]: added mount point /media/cdrecorder for /dev/hde
Apr 14 16:30:51 mmouse kernel: hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
Apr 14 16:58:28 mmouse kernel: hde: packet command error: status=0xd0 { Busy }
Apr 14 17:00:34 mmouse kernel: hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
Apr 14 17:05:18 mmouse kernel: hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
Apr 14 17:09:56 mmouse kernel: hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)

The drive appears to function normally.

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.14_FC3

How reproducible:
Always

Steps to Reproduce:
1. Boot kernel-2.6.11-1.14_FC3
2. Wait about 15 minutes
3. Messages occur
  

Actual Results:  cdrom_pc_intr: The drive appears confused (ireason = 0x01)

Expected Results:  No spurious messages

Additional info:

lspci is reporting:

00:0c.0 Unknown mass storage controller: Promise Technology, Inc. PDC20262 (Fast
Trak66/Ultra66) (rev 01)

00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/
C PIPC Bus Master IDE (rev 06)

I believe the drive reporting the problem is on 00:0c.0.

Comment 1 Dave Jones 2005-07-15 18:27:10 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 2 Mace Moneta 2005-07-16 20:07:53 UTC
I updated the kernel to 2.6.12-1.1372_FC3, and I am no longer seeing this message.


Note You need to log in before you can comment on or make changes to this bug.