Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154929 - Firefox claims to install flash plugins but lies
Summary: Firefox claims to install flash plugins but lies
Keywords:
Status: CLOSED DUPLICATE of bug 152611
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-14 21:01 UTC by David Zeuthen
Modified: 2013-03-06 03:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-01 10:31:00 UTC


Attachments (Terms of Use)

Description David Zeuthen 2005-04-14 21:01:34 UTC
Description of problem:

So, upon visiting the Macromedia website, Firefox detects that I need the Flash
plugin and offers to install it, gives me the EULA, I accept, Firefox downloads
the plugin, but install fails.

O next visit Firefox offers to install it again, I say yes, accept the EULA, ff
downloads and installs and says success. Still does not work.

I am running selinux targeted and there are no avc denied in /var/log/messages

Version-Release number of selected component (if applicable):

1.0.2-3

How reproducible:

Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 2 Roy 2005-05-01 08:48:38 UTC
The flash plugin is installed like it's supposed to be, Firefox however can't
load the plugin, and fails with the error messages:

LoadPlugin: failed to initialize shared library
/home/roy/.mozilla/plugins/libflashplayer.so
[/home/roy/.mozilla/plugins/libflashplayer.so: kan segmentbescherming niet
herstellen na verhuizing: Toegang geweigerd]
LoadPlugin: failed to initialize shared library
/usr/Mozilla/Firefox/plugins/libflashplayer.so
[/usr/Mozilla/Firefox/plugins/libflashplayer.so: kan segmentbescherming niet
herstellen na verhuizing: Toegang geweigerd]
LoadPlugin: failed to initialize shared library
/usr/Mozilla/Firefox/plugins/libvlcplugin.so
[/usr/Mozilla/Firefox/plugins/libvlcplugin.so: kan segmentbescherming niet
herstellen na verhuizing: Toegang geweigerd]
*** loading the extensions datasource
*** ExtensionManager:_updateManifests: no access privileges to application
directory, skipping.
LoadPlugin: failed to initialize shared library
/home/roy/.mozilla/plugins/libflashplayer.so
[/home/roy/.mozilla/plugins/libflashplayer.so: kan segmentbescherming niet
herstellen na verhuizing: Toegang geweigerd]
LoadPlugin: failed to initialize shared library
/usr/Mozilla/Firefox/plugins/libflashplayer.so
[/usr/Mozilla/Firefox/plugins/libflashplayer.so: kan segmentbescherming niet
herstellen na verhuizing: Toegang geweigerd]
LoadPlugin: failed to initialize shared library
/usr/Mozilla/Firefox/plugins/libvlcplugin.so
[/usr/Mozilla/Firefox/plugins/libvlcplugin.so: kan segmentbescherming niet
herstellen na verhuizing: Toegang geweigerd]
*** loading the extensions datasource
*** ExtensionManager:_updateManifests: no access privileges to application
directory, skipping.

After this, Firefox starts up like normally, but without Flash (or the vlc
plugin, for that matter). My guess is that these modules need to be recompiled
with GCC4 to fix compatibility with the FC4 kernel, althou i'm not that much of
a programmer.

Comment 3 Warren Togami 2005-05-01 10:31:00 UTC

*** This bug has been marked as a duplicate of 152611 ***


Note You need to log in before you can comment on or make changes to this bug.