Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154915 - impress doesn't advertise being able to load powerpoint files that it makes
Summary: impress doesn't advertise being able to load powerpoint files that it makes
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-14 20:28 UTC by David Zeuthen
Modified: 2013-03-06 03:43 UTC (History)
1 user (show)

Fixed In Version: 1.9.93-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-25 07:57:38 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenOffice.org 47641 None None None Never

Description David Zeuthen 2005-04-14 20:28:55 UTC
Description of problem:

The desktop file points to oocalc but should point to oocalc2 instead. Suggest
to audit all desktop files provided by this package.

Version-Release number of selected component (if applicable):

3.7.1-9

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 David Zeuthen 2005-04-14 20:56:37 UTC
So I got this all wrong, sorry. The bug is:

 The the desktop file redhat-presentations.desktop, as referenced in 
 shared-mime-info as the default for .ppt files should be in
 redhat-menus

The problem is that .ppt files can't be openened from Nautilus


Comment 2 Ray Strode [halfline] 2005-04-14 21:29:40 UTC
Hi, so there are actually two ways to fix this:

1) add application/vnd.ms-powerpoint to the MimeType= line of impress.desktop
2) create a symlink from
%{_datadir}/desktop-menu-patches/redhat-presentations.desktop
${_datadir}/applications in the %install section of the openoffice spec file
(and run update-desktop-database in %post and %postun).

1) is the upstream fix, 2) isn't a good idea because redhat-menus is probably
going away soon.



Comment 3 Caolan McNamara 2005-04-18 09:48:19 UTC
1 is the right fix, and will be in place as soon as gcc works again for OOo.
Upstreamed as ooo#47641#


Note You need to log in before you can comment on or make changes to this bug.