Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154878 - libSDL has undefined references
Summary: libSDL has undefined references
Keywords:
Status: CLOSED DUPLICATE of bug 154771
Alias: None
Product: Fedora
Classification: Fedora
Component: SDL
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-14 17:35 UTC by Yao Zhang
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-15 08:40:36 UTC


Attachments (Terms of Use)

Description Yao Zhang 2005-04-14 17:35:45 UTC
Description of problem:
When compiling a simple SDL test code, the linker complaints about
undefined references.

Version-Release number of selected component (if applicable):
SDL-1.2.8-3
SDL-devel-1.2.8-3

How reproducible:
Always

Steps to Reproduce:

Code:

#include "SDL.h"

int main(int argc, char *argv[])
{
    SDL_Surface *screen;

    if (SDL_Init(SDL_INIT_VIDEO) < 0) {
        fprintf(stderr, "Unable to init SDL: %s\n", SDL_GetError());
        return 1;
    }
    atexit(SDL_Quit);

    return 0;
}

Compile:
gcc a.c `sdl-config --cflags --libs`

Actual results:
/usr/lib/libSDL.so: undefined reference to `ConvertX86p32_16RGB565'
/usr/lib/libSDL.so: undefined reference to `ConvertX86'
/usr/lib/libSDL.so: undefined reference to `ConvertMMXpII32_16RGB565'
/usr/lib/libSDL.so: undefined reference to `ConvertX86p32_24RGB888'
/usr/lib/libSDL.so: undefined reference to `ConvertMMXpII32_16BGR555'
/usr/lib/libSDL.so: undefined reference to `ConvertX86p32_16RGB555'
/usr/lib/libSDL.so: undefined reference to `ConvertX86p32_16BGR555'
/usr/lib/libSDL.so: undefined reference to `ConvertX86p32_32BGR888'
/usr/lib/libSDL.so: undefined reference to `ConvertMMXpII32_16BGR565'
/usr/lib/libSDL.so: undefined reference to `ConvertX86p32_32BGRA888'
/usr/lib/libSDL.so: undefined reference to `ConvertX86p32_24BGR888'
/usr/lib/libSDL.so: undefined reference to `ConvertX86p32_32RGBA888'
/usr/lib/libSDL.so: undefined reference to `ConvertX86p16_16BGR555'
/usr/lib/libSDL.so: undefined reference to `ConvertX86p16_16BGR565'
/usr/lib/libSDL.so: undefined reference to `ConvertX86p32_8RGB332'
/usr/lib/libSDL.so: undefined reference to `ConvertX86p16_16RGB555'
/usr/lib/libSDL.so: undefined reference to `ConvertMMX'
/usr/lib/libSDL.so: undefined reference to `ConvertX86p32_16BGR565'
/usr/lib/libSDL.so: undefined reference to `ConvertMMXpII32_16RGB555'

Expected results:


Additional info:

Comment 1 Sammy 2005-04-14 23:41:10 UTC
Can confirm this. It is killing my mplayer with the same message. 

Comment 2 Thomas Woerner 2005-04-15 08:40:36 UTC

*** This bug has been marked as a duplicate of 154771 ***


Note You need to log in before you can comment on or make changes to this bug.