Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154867 - s-c-printer gives errors on install
Summary: s-c-printer gives errors on install
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-14 16:40 UTC by Toshio Kuratomi
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 0.6.142-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-08 12:54:32 UTC


Attachments (Terms of Use)

Description Toshio Kuratomi 2005-04-14 16:40:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

Description of problem:
When upgrading from FC3 to FC4t2, I run into bug #138493.  It appears that FC3 ran with python-2.3 and PyXML-0.8.3.  We need to upgrade to python-2.4 and PyXML-0.8.4 at the same time for s-c-printer to work.

Version-Release number of selected component (if applicable):
0.6.128-1

How reproducible:
Didn't try

Steps to Reproduce:
1. From an FC3 install with PyXML-0.8.3, upgrade system-config-printer and its _required_ dependencies.
2.
3.
  

Actual Results:    34:system-config-printer  ########################################### [ 36%]
Traceback (most recent call last):
  File "/usr/share/printconf/util/updateconf.py", line 29, in ?
    import printconf_conf as conf
  File "/usr/share/printconf/util/printconf_conf.py", line 83, in ?
    from xml.utils import qp_xml
ImportError: No module named utils

Expected Results:  Update with no errors.

Additional info:

I think the problem is s-c-printer still specifies PyXML-0.8.3 as it's minimum required version but it should require PyXML-0.8.4 instead.  Haven't tested this, but after reading bug #138493 I think the following will work::

From CVS:
--- printconf.spec      24 Mar 2005 18:12:39 -0000      1.36
+++ printconf.spec      14 Apr 2005 16:37:33 -0000
@@ -11,7 +11,7 @@
 BuildRequires: gettext, desktop-file-utils >= 0.2.92
 BuildRequires: cups-devel, python-devel, intltool
 PreReq: alchemist >= 1.0.33, python, python-abi = %{pyver}
-PreReq: perl, PyXML >= 0.8.3-2
+PreReq: perl, PyXML >= 0.8.4-1
 PreReq: fileutils, initscripts
 PreReq: rhpl >= 0.81
 Requires: m4, perl, pnm2ppa

Comment 1 Tim Waugh 2005-04-19 16:49:12 UTC
Please try 0.6.129-1.

Comment 2 Toshio Kuratomi 2005-04-19 18:55:43 UTC
Still gives errors. From system-config-printer built from today's CVS checkout::

# rpm -Uvh system-config-printer-0.6.129-1.i386.rpm
Preparing...                ########################################### [100%]
   1:system-config-printer  ########################################### [100%]
Traceback (most recent call last):
  File "/usr/share/printconf/util/updateconf.py", line 29, in ?
    import printconf_conf as conf
  File "/usr/share/printconf/util/printconf_conf.py", line 83, in ?
    from xml.utils import qp_xml
ImportError: No module named utils


Is there a reason
  PreReq: PyXML >= 0.8.4-1
as given in the previous patch snippet is wrong?  I tried another version with
that change made and things work as expected::

  -bash-3.00# rpm -Uvh system-config-printer-0.6.129-1.test.1.i386.rpm
  error: Failed dependencies:
        PyXML >= 0.8.4-1 is needed by system-config-printer-0.6.129-1.test.1.i386
  -bash-3.00# yum update PyXML
  ......
  -bash-3.00# rpm -Uvh system-config-printer-0.6.129-1.test.1.i386.rpm
  Preparing...                ########################################### [100%]
     1:system-config-printer  ########################################### [100%]
  -bash-3.00#

Comment 3 Tim Waugh 2005-04-20 08:26:07 UTC
Nothing more we can do at a package level, as far as I can see.

Comment 4 Tim Waugh 2005-04-20 08:26:19 UTC
Reassigning.

Comment 5 Toshio Kuratomi 2005-04-20 11:44:42 UTC
(In reply to comment #3)
> Nothing more we can do at a package level, as far as I can see.

In the current spec file the PreReq line is:
  PreReq: PyXML >= 0.8.3-2
I've tested that:
  PreReq: PyXML >= 0.8.4-1
does the expected thing.

If there's a reason not to do that, tell me.   Otherwise it seems like the
correct fix as it uses rpm's existing facilities for enforcing the requisite
update ordering.

Comment 6 Jeff Johnson 2005-08-27 02:52:43 UTC
Why is this assigned to rpm? I see no rpm problem described here ...

Comment 7 Tim Waugh 2005-09-05 12:05:29 UTC
Fixed in CVS.


Note You need to log in before you can comment on or make changes to this bug.