Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154859 - GdkPixbuf-CRITICAL, file picker preview warnings
Summary: GdkPixbuf-CRITICAL, file picker preview warnings
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 3
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-14 16:07 UTC by Tim Waugh
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-19 16:55:56 UTC


Attachments (Terms of Use)

Description Tim Waugh 2005-04-14 16:07:29 UTC
Description of problem:
I noticed this assertion failure message while using OpenOffice.org Writer.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.3-11.5.0.fc3

How reproducible:
Couldn't find out how to reproduce this.

Actual results:
(soffice.bin:11891): GdkPixbuf-CRITICAL **: file gdk-pixbuf-io.c: line 874
(size_prepared_cb): assertion `width > 0 && height > 0' failed

Comment 1 Caolan McNamara 2005-04-19 09:07:38 UTC
This is presumably a file in a directory being browsed by the file browser with
preview enabled and the code passing the files to gtk_pixbuf_load_from_file and
one of them is triggering this problem. Right now in 1.9.92 and browsing with
insert->picture with preview enabled I can browse files which gtk cannot
preview, e.g. eps and I don't see this message, so I wonder if the problem is
gone in 1.9.92. If you could find which file is causing the problem by
re-rebrowsing with insert->picture I could verify that it's fixed in 1.9.92. 

It's only a cosmetic problem, the only thing it can relate to is that a preview
in insert->picture cannot be manufactured because either the file being browsed
is corrupt, or there is some other SNAFU.

Comment 2 Tim Waugh 2005-04-19 16:55:56 UTC
Couldn't find what caused it I'm afraid.


Note You need to log in before you can comment on or make changes to this bug.