Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154854 - PAM account fails for local user when LDAP is unreachable
Summary: PAM account fails for local user when LDAP is unreachable
Keywords:
Status: CLOSED DUPLICATE of bug 109359
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: pam
Version: 4.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Tomas Mraz
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-14 15:47 UTC by Shane A. Stillwell
Modified: 2015-01-08 00:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-18 08:41:29 UTC


Attachments (Terms of Use)

Description Shane A. Stillwell 2005-04-14 15:47:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
I have two users in /etc/passwd (root, admin), the rest are in LDAP.  I have set the system to authenticate users via LDAP (using authconfig).

When LDAP is running everything works fine, but when LDAP is stopped, root can ssh in but the local user "admin" cannot.

The offending line in /etc/pam.d/system-auth is 
account     [default=bad success=ok user_unknown=ignore] /lib/security/$ISA/pam_ldap.so

After commenting this line out in system-auth, the admin user can now ssh in even when LDAP is down.  

Local users in /etc/passwd should not be denied access ssh (login) access when LDAP is down.


Version-Release number of selected component (if applicable):
pam-0.77-65.1

How reproducible:
Always

Steps to Reproduce:
1. Set up local (/etc/passwd) users and LDAP users
2. Set up server to authenticate via LDAP
3. Shutdown LDAP
4. Try to ssh in with non root local account.
5. You will keep getting a password prompt.
  

Actual Results:  When trying to SSH in as a non-root local user with LDAP down, keep getting a password prompt.

Expected Results:  Get ssh'd in.

Additional info:

This seems to be the offending line in /etc/pam.d/system-auth
account     [default=bad success=ok user_unknown=ignore] /lib/security/$ISA/pam_ldap.so

Comment 1 Tomas Mraz 2005-04-18 08:41:29 UTC

*** This bug has been marked as a duplicate of 109359 ***


Note You need to log in before you can comment on or make changes to this bug.