Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154832 - Request support for Linksys WUSB11 Wireless USB Adapter
Summary: Request support for Linksys WUSB11 Wireless USB Adapter
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-14 14:38 UTC by David W. Legg
Modified: 2015-01-04 22:18 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-21 22:58:40 UTC


Attachments (Terms of Use)

Description David W. Legg 2005-04-14 14:38:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.6) Gecko/20050321 Firefox/1.0.2

Description of problem:
The WUSB11 wireless USB adapter is quite a common device and is support by the wlan prism2_usb driver. Wouldn't it be cool to have it supported by Fedora out-of-the-box, both in the kernel and the wireless-tools package.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Plug in WUSB11


Actual Results:  /var/log/messages indicates device not recognised by a driver.
Only the USB adapter itself is spotted.

Expected Results:  The prism_usb module should get loaded and the redhat-network-config tool should enable the user to configure the network interface.

Additional info:

Comment 1 Rik van Riel 2005-04-14 17:05:09 UTC
David,

is the prism2_usb driver in the upstream kernel ?

If not, this would be better done as an external kernel module RPM in Fedora
Extras...

Comment 2 David W. Legg 2005-04-14 21:37:27 UTC
Either way seems fine to me.

How does one look inside the upstream kernel?

But why leave it festering amongst the extras? It must be a popular device
because it is well established and cheap.

Comment 3 Dave Jones 2005-04-21 22:58:40 UTC
the problem with merging this into Fedora is that it uses wireless
infrastructure (wlan-ng) that isnt currently present in the kernel, and merging
it would effectively fork our wireless support from that as shipped in
kernel.org kernels, which isn't going to happen.

I'd suggest further discussion on getting this merged upstream happen on the
wlan-ng mailing lists, and/or netdev@oss.sgi.com


Note You need to log in before you can comment on or make changes to this bug.