Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154812 - Download selected packages button generates 500 error every time
Summary: Download selected packages button generates 500 error every time
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site
Version: rhn410
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Ryan Newberry
QA Contact: Vlady Zlatkin
URL: https://rhn.redhat.com/network/softwa...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-14 11:33 UTC by Red Hat Production Operations
Modified: 2013-08-06 03:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-10-11 13:25:51 UTC


Attachments (Terms of Use)

Description Red Hat Production Operations 2005-04-14 11:33:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/125.5.7 (KHTML, like Gecko) Safari/125.12

Description of problem:


Version-Release number of selected component (if applicable):
All

How reproducible:
Always

Steps to Reproduce:
1. Go to any Channel that we currently serve packages out of
2. Mark checkboxes next to multiple packages
3. Click the "Download Packages button
4. Follow the instructions to "Download packages now", which redirects you to URL:

https://rhn.redhat.com/cgi-bin/download.pl/rhn-packages.tar

which generates the 500 error.

Actual Results:  Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Expected Results:  I should have been able to download packages.  There have been multiple customer reports of this to 
soc@redhat.com.

Additional info:

Comment 1 Matthew Galgoci 2006-05-12 21:48:16 UTC
The problem seems to be due to not properly escaping characters in rpm names,
such as the + symbol in libstdc++ or gcc-c++

Comment 2 Matthew Galgoci 2006-08-02 19:43:15 UTC
This problem is still present in the rhn 410 code base.

Comment 3 Ryan Newberry 2006-09-25 17:10:34 UTC
I cannot reproduce the issue in webdev or production. Is this maybe something
that is browser specific?

Comment 4 Matthew Galgoci 2006-09-25 18:38:41 UTC
Please stop by my cube for a demonstration. Thanks.

Comment 5 Ryan Newberry 2006-09-29 20:04:01 UTC
Just wondering if an account that can consistently cause this error to occur was
found

Comment 6 Ryan Newberry 2006-10-11 13:25:51 UTC
There isn't an account that can reproduce this bug consistently. Since I can't
reproduce it, closing it.


Note You need to log in before you can comment on or make changes to this bug.