Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154811 - no sound output (intel_8x0)
Summary: no sound output (intel_8x0)
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-14 11:33 UTC by Luicil Fernandes
Modified: 2015-01-04 22:18 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-15 00:38:23 UTC


Attachments (Terms of Use)

Description Luicil Fernandes 2005-04-14 11:33:38 UTC
Hi,
I'm very new to linux. My oppinion is a fantastic SO, but...

Running up2date I updated my kernel to: Fedora Core (2.6.10-1.770_FC3)
My sound card stoped. No more sounds...

Then this week (04/12/2005), running up2date again, my kernel was updated to:
Fedora Core (2.6.11-1.14_FC3)
My sound card and my mouse stoped working.

I'm using a toshiba notebook Satellite A10 S-177. My mouse is a touchpad mouse.

If I run the kernel: Fedora Core (2.6.9-1.667) everything runs ok !

What could be happening ?

TIA

Comment 1 Dave Jones 2005-04-14 19:27:59 UTC
can you paste the output of lspci please ?

also, please check the volume control panel to ensure everything is unmuted and
volumes are not at zero.


Comment 2 Luicil Fernandes 2005-04-14 20:31:40 UTC
Sure,

The volume control is ok. If I start with Fedora Core 2.6.9 sound is ok, with no
changes but starting with Fedora core 2.6.10 no sound and no mouse too !!!

I'm not sure if I did right what you wish: here is what I got typeing lspci in
console:

00:00.0 Host bridge: Intel Corp. 82852/82855 GM/GME/PM/GMV Processor to I/O
Controller (rev 01)
00:00.1 System peripheral: Intel Corp. 82852/82855 GM/GME/PM/GMV Processor to
I/O Controller (rev 01)
00:00.3 System peripheral: Intel Corp. 82852/82855 GM/GME/PM/GMV Processor to
I/O Controller (rev 01)
00:02.0 VGA compatible controller: Intel Corp. 82852/855GM Integrated Graphics
Device (rev 01)
00:02.1 Display controller: Intel Corp. 82852/855GM Integrated Graphics Device
(rev 01)
00:1d.0 USB Controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB
UHCI Controller #1 (rev 03)
00:1d.7 USB Controller: Intel Corp. 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI
Controller (rev 03)
00:1e.0 PCI bridge: Intel Corp. 82801 Mobile PCI Bridge (rev 83)
00:1f.0 ISA bridge: Intel Corp. 82801DBM (ICH4-M) LPC Interface Bridge (rev 03)
00:1f.1 IDE interface: Intel Corp. 82801DBM (ICH4-M) IDE Controller (rev 03)
00:1f.5 Multimedia audio controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
00:1f.6 Modem: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem
Controller (rev 03)
01:08.0 Ethernet controller: Intel Corp. 82801DB PRO/100 VE (MOB) Ethernet
Controller (rev 83)
01:0b.0 CardBus bridge: Toshiba America Info Systems ToPIC95 PCI to Cardbus
Bridge with ZV Support (rev 33)
02:00.0 Network controller: Intersil Corporation Intersil ISL3890 [Prism
GT/Prism Duette] (rev 01)

TIA


Comment 3 Dave Jones 2005-04-14 21:35:23 UTC
please try toggling the 'External Amplifier' in the volume panel.

sounds like a dupe of https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=154698

Comment 4 Luicil Fernandes 2005-04-14 23:52:12 UTC
rsrs Amazing !

I toogled the 'Headphone Jack Sense' and now I have sounds !!! I don't know if 
it make sense but is working now !

Toogling the 'External Amplifier' had no effect !

Thanks !!!

Great work !!!

50% solved, just need to know how to put my touchpad mouse to work now ! With 
2.6.9 core it works fine but with 2.6.11-1.14_FC3 not !

TIA


Comment 5 Luicil Fernandes 2005-04-15 00:26:21 UTC
About my mouse:

In 2.6.9 core kernel, using the Hardware Browser, my Pointing devices shows 
me: 
PS/2 Generic Mouse, Driver: generic3ps/2, Device: /dev/input/mice
This works fine !

In 2.6.11 core kernel, using the Hardware Browser, Pointing devices shows me:
AlpsPS/2 ALPS TouchPad, Driver: generic3ps/2, Device: /dev/input/mice
The device is correct, but the mouse does not work correctly !

Thanks ...

Comment 6 Dave Jones 2005-04-15 00:38:23 UTC
the touchpad problem is already known about (theres a bunch of bugzillas on this
already).

As your sound now works, I'll close this out.



Note You need to log in before you can comment on or make changes to this bug.