Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154807 - no sound with kernel 2.6.11
Summary: no sound with kernel 2.6.11
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-14 11:00 UTC by Thilo Pfennig
Modified: 2015-01-04 22:18 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-15 22:53:06 UTC


Attachments (Terms of Use)

Description Thilo Pfennig 2005-04-14 11:00:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
After I installed the new kernel. (I used kernel-2.6.10-1.770_FC3 before) I did not hear any sound. I have a KT400 board. After switching to the old kernel the sound is still gone.





Version-Release number of selected component (if applicable):
kernel-2.6.11-1.14_FC3

How reproducible:
Always

Steps to Reproduce:
1. play a audio file
  

Actual Results:  audio file is played but no sound is heard.

Expected Results:  sound should be heared.

Additional info:

With the new kernel there is no PCM or Master Volume.

some things fron lspci -v:

00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 50)
        Subsystem: ASRock Incorporation: Unknown device 9761
        Flags: medium devsel, IRQ 3
        I/O ports at dc00 [size=256]
        Capabilities: <available only to root>

/sbin/lsmod |grep snd                                                 ~
snd_via82xx            27745  3
snd_ac97_codec         67489  1 snd_via82xx
snd_pcm_oss            47989  0
snd_mixer_oss          17089  2 snd_pcm_oss
snd_pcm                93001  4 snd_via82xx,snd_ac97_codec,snd_pcm_oss
snd_timer              29125  1 snd_pcm
snd_page_alloc          9541  2 snd_via82xx,snd_pcm
gameport                4929  1 snd_via82xx
snd_mpu401_uart         9025  1 snd_via82xx
snd_rawmidi            25953  1 snd_mpu401_uart
snd_seq_device          8525  1 snd_rawmidi
snd                    52645  12 snd_via82xx,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore              10017  2 snd


PS: I also added a onboard MPU in the BIOS. Maybe this also changed some things. Fact is, the KT400 is not well supported by the new kernels, many people say this.

Comment 1 Dave Jones 2005-07-15 20:17:54 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 2 Thilo Pfennig 2005-07-15 20:35:12 UTC
the bugs seems to be resolved.


Note You need to log in before you can comment on or make changes to this bug.