Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154787 - iiimd crash when LE loads
Summary: iiimd crash when LE loads
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: iiimf-le-chinput
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Yu Shao
QA Contact:
URL:
Whiteboard:
Depends On: 153962
Blocks: IIIMF FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-04-14 06:10 UTC by Lawrence Lim
Modified: 2014-03-26 00:52 UTC (History)
2 users (show)

Fixed In Version: iiimf-le-chinput-0.3-19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-22 04:18:17 UTC


Attachments (Terms of Use)

Description Lawrence Lim 2005-04-14 06:10:49 UTC
Description of problem:
Everything an application starts in the zh_CN locale, chinput gets loaded and
crashs the iiimd.

Version-Release number of selected component (if applicable):
iiimf-le-chinput-0.3-18
iiimf-12.1.1-14.svn2476

How reproducible:
Always

Steps to Reproduce:
1.log in at gdm with ja locale
2.'ps auxwww |grep iiim' to check for iiimd process id
3.in g-t, LANG=zh_CN.UTF-8 gedit
4.'ps auxwww |grep iiim' to check for iiimd process id
  
Actual results:
iiimd crash

Expected results:
iiimd should not crash

Additional info:

Comment 1 Akira TAGOH 2005-04-18 08:49:50 UTC
For more information, iiimd with -d option says below.
requested lang = zh_CN
requested desc = chinput
Opening resource file /usr/lib/iiim/le/chinput/Chinput.ad
Cannot open resource file Chinput.ad

and Chinput.ad was packaged as:
/usr/lib/iiim/le/locale/zh_CN/chinput/Chinput.ad

It looks like mispackaging and new IIIMF file hierarchy transition is incomplete.

Comment 2 Lawrence Lim 2005-04-22 04:18:17 UTC
Confirmed fixed. Tested with iiimf-le-chinput-0.3-19, the LE is in working
condition now.


Thanks.


Note You need to log in before you can comment on or make changes to this bug.