Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154777 - FC4T2 (or T1) will not print to a turboprint 1.91-2 defined printer
Summary: FC4T2 (or T1) will not print to a turboprint 1.91-2 defined printer
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted
Version: 4
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
Depends On:
TreeView+ depends on / blocked
Reported: 2005-04-14 03:11 UTC by Gerry Tool
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2005-05-04 00:49:12 UTC

Attachments (Terms of Use)
requested result of grep /var/log/messages (deleted)
2005-04-26 01:57 UTC, Gerry Tool
no flags Details
requested results of grep avc /var/log/audit/audit.log (deleted)
2005-04-26 02:00 UTC, Gerry Tool
no flags Details
requested results of grep avc /var/log/audit/audit.log (deleted)
2005-04-28 01:24 UTC, Gerry Tool
no flags Details
requested result of grep /var/log/messages (deleted)
2005-04-28 01:25 UTC, Gerry Tool
no flags Details

Description Gerry Tool 2005-04-14 03:11:46 UTC
Description of problem:Application turboprint 1.91-2 from does not
work with FC4Tx - it has worked with all former RHL and FC versions.

Version-Release number of selected component (if applicable):

How reproducible:Always

Steps to Reproduce:
1.Install turboprint 1.91-2 from rpm
2.Setup turboprint for a networked LPD print server
3.Try to print a test page or print from an app.
Actual results: No printing occurs.  Printer interface believes all is well -
both turboprint setup and localhost:631 interfaces.  Defined printer shows up in
printer dialogs in apps such as gedit.  Printing appears to work, but nothing
ever happens at the printer.

Expected results: Page should print

Additional info: Printing is working for a Samsung ML-1750 laser printer
attached to a second port on the networked LPD print server.  Turboprint defined
printers identical to this setup work in FC3, FC2, ubuntu 5.04, suse9.2 and
several other distros I've tried.

I have reported this bug to also.

Comment 1 Tim Waugh 2005-04-14 09:00:25 UTC
If you find that the cause is a CUPS bug, please re-open.

Comment 2 Gerry Tool 2005-04-23 03:38:27 UTC
It occurred to me that SELinux might be involved.  I disabled SELinux, and the
Canon printer prints via Turbolinux.  I reenabled, and left it set to Permissive
and it still prints.  I set it to Enforce, and it does not print.

So, it appears that SELinux set to Enforce will not allow Turboprint/Canon
printer to print, whereas set to Permissive does.

I do not understand SELinux well enough to know if there is some parameter in
SELinux that I can change to allow Enforce to work along with Turboprint.

Comment 3 Daniel Walsh 2005-04-25 15:00:54 UTC
You should see AVC messages in you log files that will tell us what SELinux is
denying.  Please attach the AVC messages.


Comment 4 Gerry Tool 2005-04-26 00:01:44 UTC
I would like to do that, but evidently do not know where to look.  If I do a
grep AVC * 
in the /var/log directory, I get nothing.

Also, what condition do you want set in the SELinux tab in Security Level
Configuration when I do this?  Printing succeeds if SELinux is Enabled, but
Enforcing is set to Permissive; it fails if Enforcing is set to Enforcing.


Comment 5 Daniel Walsh 2005-04-26 01:43:13 UTC
grep  avc /var/log/messages  
grep avc /var/log/audit/auditd.log

Comment 6 Gerry Tool 2005-04-26 01:57:10 UTC
Created attachment 113658 [details]
requested result of grep /var/log/messages

Comment 7 Gerry Tool 2005-04-26 02:00:03 UTC
Created attachment 113659 [details]
requested results of grep avc /var/log/audit/audit.log

There was no /var/log/audit/auditd.log file, so this attachment is the result
of grep avc /var/log/audit/audit.log

Comment 8 Daniel Walsh 2005-04-26 17:20:16 UTC
Fixed in selinux-policy-*-1.23.13-3

Comment 9 Gerry Tool 2005-04-28 01:22:25 UTC
I now have this installed:

[root@gst-fc4t2 ~]# rpm -q selinux-policy-targeted

and I still must have SELinux Enforcing Current: Permissive to print.

If I set it to SELinux Enforcing Current : Enforcing,
the print job completes according to Document print status, but nothing prints.

I will again attach the files you previously requested.

Comment 10 Gerry Tool 2005-04-28 01:24:57 UTC
Created attachment 113752 [details]
requested results of grep avc /var/log/audit/audit.log

Comment 11 Gerry Tool 2005-04-28 01:25:44 UTC
Created attachment 113753 [details]
requested result of grep /var/log/messages

Comment 12 Gerry Tool 2005-05-04 00:49:12 UTC
This bug now appears to be fixed with:
[root@gst-fc4t2 ~]# rpm -q selinux-policy-targeted

I can now print via a turboprint-defined printer with SELinux set to enforcing.

Thanks for the bug fix.

Gerry Tool

Note You need to log in before you can comment on or make changes to this bug.