Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154765 - Can't add -y to /fsckoptions
Summary: Can't add -y to /fsckoptions
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: initscripts
Version: 4.0
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-14 01:12 UTC by Wojciech Palacz
Modified: 2014-03-17 02:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-21 19:50:37 UTC


Attachments (Terms of Use)

Description Wojciech Palacz 2005-04-14 01:12:25 UTC
Description of problem:
rc.sysinit does not support fully automatic filesystem checking (fsck -y)

Version-Release number of selected component (if applicable):
initscripts-7.93.11.EL-1

How reproducible:
always

Steps to Reproduce:
1. echo "-y" > /fsckoptions
2. reboot
  
Actual results:
after reboot root filesystem check fails due to conflicting switches
given to fsck: fsck -a -y

Expected results:
system should boot up normally, doing filesystem checks with fsck -y
instead of fsck -a

Additional info:
easy workaround is to edit /etc/rc.d/rc.sysedit manually, and replace
all occurences of 'fsck -T -a ...' with 'fsck -T -y ...'

Comment 1 Bill Nottingham 2005-09-21 19:50:37 UTC
Moving this bug to the Fedora Core development stream, so it can be considered
for  upstream development for later RHEL releases. It is unlikely that this
change will be made for RHEL 4.


Note You need to log in before you can comment on or make changes to this bug.