Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154764 - kernel panic on shutdown not syncing drivers/block/cfq-iosched.c
Summary: kernel panic on shutdown not syncing drivers/block/cfq-iosched.c
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-14 00:51 UTC by Russell East
Modified: 2015-01-04 22:18 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-14 02:18:26 UTC


Attachments (Terms of Use)

Description Russell East 2005-04-14 00:51:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
Today I downloaded and installed all the available updates from yum.  This included the above kernel update amongst other things.  My system is a Dell D800 Latitude.  At the same time I installed the madwifi kernel update to correspond - madwifi-kmdl-2.6.11-1.14_FC3-0.9.4.12-15.rhfc3.at - as well as the latest NVidia driver (7174).  After the install and rebooting all seemed fine.  I logged and did a couple hours work at home using the wireless net.  Then it was time to actually go to work.  First I performed a simple backup to a (USB) thumbdrive, unmounted the drive, then logged out of KDE.  Then I selected shutdown.  Several messages appeared as usual, followed by the following:
  Kernel panic - not syncing: drivers/block/cfq-iosched.c:1065: spin_is_locked on uninitialized spinlock f4117c1c. (Tainted: P     )

(it is copied by hand from screen).  Following this I shut off the power, then rebooted and shutdown properly, no problem.  t makes me think the backup to thumbdrive might be the culprit.  Later, at end of work again I made backup to thumbdrive (hoping it was a one off) but no, exact same situation and message.

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.14_FC3

How reproducible:
Always

Steps to Reproduce:
see above

Actual Results:  see above

Additional info:

Did not have this problem with previous kernel - kernel-2.6.10-1.770_FC3

Comment 1 Dave Jones 2005-04-14 02:18:26 UTC
reopen if you can reproduce without the modules causing a tainted kernel.


Comment 2 Russell East 2005-04-14 14:04:59 UTC
I have 3 items that cause a tainted kernel - NVidia graphics, madwifi wireless
and VmWare.  It is hardest to get rid of nvidia, so I temporarily removed VmWare
and madwifi then rebooted.  Problem still remained with NVidia v1.0-7174.  So I
reverted to previous version NVidia v1.0-7167, rebooted, can could not repro. 
Encouraged with that, I re-loaded the madwifi, rebooted and tried again, but
found the problem recurred.  Since I cannot work without nvidia or madwifi, my
next step was to revert the kernel to previous 2.6.10-1.770_FCS.  At same time,
I re-loaded new 7174 nvidia driver, madwifi driver corresponding to the kernel,
and re-loaded VmWare.  All reloaded, I rebooted, ran the test and it all seems
to be working.  So, it looks like my workaround is to stay with 2.6.10 kernel
and wait for future updates before trying with 2.6.11 again.

Comment 3 Jacek Piskozub 2005-04-15 07:21:18 UTC
I had the same very error yesterday when closing the system. The only module
tainting the kernel I have is the Nvidia driver.

Comment 4 Vlado Potisk 2005-04-30 07:19:43 UTC
I've got exactly the same kernel panic already twice since I installed the
2.6.11 FC3 kernel. It happened while I was working in KDE (just the hex address
of the spinlock was different). My kernel is not tainted.

Comment 5 Vlado Potisk 2005-04-30 08:57:05 UTC
In bug #155381 (dup?) there is a fix (prerelease kernel from rawhide).

Comment 6 Adam Pribyl 2005-05-24 11:56:00 UTC
Same happens to me. Message:
Kernel panic - not syncing: drivers/block/cfq-iosched.c:1065 spin_is_locked on
uninitialized spinlock e637381c (Not Tained)

kernel 2.6.11-1.14. It happens almost always on shutdown/reboot after some time
machine is running. It also causes "strange" freezes while shuting down from gui
as machine freezes withou any message on the screen. It does not happen with
some older kernels.

Comment 7 Russell East 2005-05-24 12:55:37 UTC
Got some good news.  Last night installed kernel 2.6.11-1.27_FC3 plus
appropriate updates for madwifi, and all now seems to work fine.  Well, what
happens is, I hold my breath and cross my fingers whenever I shutdown, and so
far, no kernel panic are happening.  Must be the voodoo!


Note You need to log in before you can comment on or make changes to this bug.