Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154739 - Network manager startup should come up before other network services...
Summary: Network manager startup should come up before other network services...
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-13 21:33 UTC by Brian G. Anderson
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-16 20:22:05 UTC


Attachments (Terms of Use)

Description Brian G. Anderson 2005-04-13 21:33:20 UTC
Description of problem:
I have a working NetworkManager that automatically connects to my wireless
network when I log in.  However, I get failures during startup because routerd
and ntpd fail because the network isn't up yet.  I'm sure other network services
would fail also.

These services should start after NetworkManager brings up the current connection.

Version-Release number of selected component (if applicable):
NetworkManager-0.4-6.cvs20050404


How reproducible:


Steps to Reproduce:
1. setup fedora to let network manager start connections, so all interfaces are
disabled on boot
2. reboot
3.
  
Actual results:
setting network time, ntpd, and starting router discovery failssssss because the
network is not up yet.


Expected results:
These services should be started after network manager brings the connection up.


Additional info:

Comment 1 Dan Williams 2005-05-16 20:22:05 UTC
yep... this isn't going to get fixed until FC5 when we get better initscripts. 
Things dealing with networking right now are quite dumb because we have to
account for network mounted /usr directories, and NetworkManager resides on /usr
(as does hal, dbus, and glib).


Note You need to log in before you can comment on or make changes to this bug.