Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154732 - Evolution's Alarm dialog can lock up X display
Summary: Evolution's Alarm dialog can lock up X display
Keywords:
Status: CLOSED DUPLICATE of bug 154731
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: evolution
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-13 21:03 UTC by Dave Malcolm
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-14 15:43:16 UTC


Attachments (Terms of Use)

Description Dave Malcolm 2005-04-13 21:03:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050322 Firefox/1.0.1 Fedora/1.0.1-6

Description of problem:
dpeternell demonstrated a problem where the evolution-alarm-notify dialog had popped up whilst the "To:" autocomplete dropdown had appeared.

It had become impossible to click on any UI elements in the X display.  Keyboard events continued to be processed.

Appears to require sysadmin intervention before the user can regain control of the session (switching to a virtual terminal with Ctrl-Alt-F1 then killing the evolution-alarm-notify process does the trick, but an end-user can't be expected to know that)

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Run Evolution, 
2. Set up an LDAP adressbook source; enable autocompletion for that source.
3. set up an alarm due to happen in next minute
4. Start composing an email; start typing in To: and try to get autocomplete to fire as the alarm dfialog pops up.
  

Actual Results:  Display appears to lock up.

Additional info:

evolution-2.0.2-14

Comment 1 Suzanne Hillman 2005-04-14 15:43:16 UTC

*** This bug has been marked as a duplicate of 154731 ***


Note You need to log in before you can comment on or make changes to this bug.