Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154706 - LABEL directives in fstab cause machine to fail to boot
Summary: LABEL directives in fstab cause machine to fail to boot
Keywords:
Status: CLOSED DUPLICATE of bug 125939
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda
Version: 4.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-13 16:50 UTC by William D. Hamblen
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-18 19:28:02 UTC


Attachments (Terms of Use)

Description William D. Hamblen 2005-04-13 16:50:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

Description of problem:
I installed WS 4 on a Latitude D600.  It created an fstab something like what I've pasted below where hda1=vfat_diag_part, hda2=windowsXP, hda3=/boot, hda4=ext, hda5=swap, hda6=/.  I was overwriting a SuSE install if that makes any difference.  Sorry I have to work from memory, but this fstab is correct in the essentials.

LABEL=/                 /                       ext3    defaults        1 1
LABEL=/boot1            /boot                   ext3    defaults        1 2
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /dev/shm                tmpfs   defaults        0 0
none                    /proc                   proc    defaults        0 0
none                    /sys                    sysfs   defaults        0 0
LABEL=SWAP-hda5         swap                    swap    defaults        0 0

After the installation finished, the machine dropped me to recovery mode during the first boot - complaining that it couldn't fsck.ext3 /dev/hda5 (that's swap).  I rebooted several times and it was always the same.  Also, df showed that /boot was mounted but was the same size and space used as / (clearly not true) yet ls showed /boot was empty.  /etc/mtab showed that these were mounted rw but that was also not true.  swap was not mounted either.  

If I remounted / rw and mounted /boot and turned on swap the system seemed normal.  I eventually fixed this by removing *all* the LABEL directives and replacing them with the device names (just doing swap wasn't enough, nor was rerunning mkswap). 

I wish I had taken notes to give a better bug report but I didn't so this is all I have.  Sorry.  The anaconda logs are available if that's useful.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:

Comment 1 Chris Lumens 2005-04-18 19:28:02 UTC

*** This bug has been marked as a duplicate of 125939 ***


Note You need to log in before you can comment on or make changes to this bug.