Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154704 - Java does not seem to build CLASSPATH properly
Summary: Java does not seem to build CLASSPATH properly
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.4.2-gcj-compat
Version: rawhide
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Fitzsimmons
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-13 16:46 UTC by W. Michael Petullo
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-15 19:25:29 UTC


Attachments (Terms of Use)

Description W. Michael Petullo 2005-04-13 16:46:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.7.6) Gecko/20050322 Epiphany/1.5.8

Description of problem:
The java command does not seem to build Java's CLASSPATH properly.  If I add statement to the script that prints the contents of CLASSPATH right before gij is executed, I get:

/usr/share/java/libgcj-java version 1.4.2.jar

There are two problems with this:

1.  This path is not correct.

2.  If I execute gij with CLASSPATH not set, gij will search "." by default.  However, if I execute java with CLASSPATH not set, java will build a CLASSPATH that does not include ".".  As a result, java will not search "." by default.

Version-Release number of selected component (if applicable):
java-1.4.2-gcj-compat-1.4.2.0-40jpp_14rh

How reproducible:
Always

Steps to Reproduce:
1.  Select a program that uses classes in ".".

2.  Execute the program using gij.

3.  Execute the program using java.
  

Actual Results:  Step 2 succeeds.  Step 3 fails because "." is not searched for classes.

Expected Results:  Steps 2 and 3 should succeed.

Additional info:

Comment 1 Thomas Fitzsimmons 2005-04-15 19:25:29 UTC
Fixed in Rawhide.  Closing.



Note You need to log in before you can comment on or make changes to this bug.