Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1546668 - [UI] Option to disable auto-sync per provider
Summary: [UI] Option to disable auto-sync per provider
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network
Version: future
Hardware: Unspecified
OS: Unspecified
medium
high vote
Target Milestone: ovirt-4.2.2
: ---
Assignee: Dominik Holler
QA Contact: Meni Yakove
URL:
Whiteboard:
Depends On:
Blocks: 1548815
TreeView+ depends on / blocked
 
Reported: 2018-02-19 09:53 UTC by Mor
Modified: 2018-05-02 07:27 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
You can now enable and disable auto-sync per external network provider. The Automatic Synchronization property of a network provider can be set when creating a new provider, and changed when editing an existing provider.
Clone Of:
Environment:
Last Closed: 2018-03-29 11:01:43 UTC
oVirt Team: Network
rule-engine: ovirt-4.2+
ylavi: exception+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 88132 master MERGED webadmin: Enable access to autoSync propertie in UI 2018-02-28 10:35:06 UTC
oVirt gerrit 88283 ovirt-engine-4.2 MERGED webadmin: Enable access to autoSync propertie in UI 2018-02-28 16:51:10 UTC

Description Mor 2018-02-19 09:53:18 UTC
Description of problem:
There should be an option to disable the auto-sync mechanism in the UI, either per cluster (preferable) or per provider. Currently, we allow this only through REST. As a result, users will be enforced to use it without an easy option (through UI) to disable it.

Version-Release number of selected component (if applicable):
4.2.1.6-0.1.el7

How reproducible:
100%

Steps to Reproduce:
Scenario 1 - edit:
1. Try to edit 'ovirt-provider-ovn'

Scenario 2- add:
1. Try to add new external network provider.

Actual results:
There is no option for disabling auto-sync.

Expected results:
Should be a checkbox in the provider window.

Additional info:

Comment 1 Mor 2018-02-19 09:56:37 UTC
In addition, if we can expose the 'ExternalNetworkProviderSynchronizationRate' setting in the UI (without having to restart ovirt-engine) it will be nice.

Comment 2 Dan Kenigsberg 2018-02-19 15:21:30 UTC
This is particularly a problem in an upgrade scenario. Assume that a user has hand-picked the network that he or she import into RHV. Then, we upgrade and auto-sync everything en mass. This is impolite. I think we should have auto-sync on by default, but it should be off for existing providers.

It could be nice to select autosync per cluster, but that would clutter the api, ui, and implementation. I'd rather have it in provider granularity.

Comment 3 Dan Kenigsberg 2018-02-21 11:43:31 UTC
Let this bug track the limited per-provider checkbox. For something fancier, please file another bug (which we are unlikely to implement soon).

Comment 4 Mor 2018-02-22 08:56:40 UTC
Is it a blocker for the autosync RFE?

Comment 5 Mor 2018-03-06 09:55:02 UTC
Verified on:
RHV 4.2.2.2-0.1.el7

Comment 6 Sandro Bonazzola 2018-03-29 11:01:43 UTC
This bugzilla is included in oVirt 4.2.2 release, published on March 28th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.2 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Comment 7 Michael Burman 2018-05-02 06:11:41 UTC
Hi Dominik, what is the default when creating provider? does the auto-sync is enabled or disabled?

Comment 8 Michael Burman 2018-05-02 06:29:15 UTC
Currently the default is - auto-sync=disabled for new provider which doesn't what written in - http://file.bne.redhat.com/~bburmest/1548815/#Adding_an_External_Network_Provider

Comment 9 Dominik Holler 2018-05-02 06:56:39 UTC
The ovirt-provider-ovn is created by engine-setup with auto-sync=enabled, while the "Add Provider" dialog (and the REST-API) has auto-sync=disabled as default.

Comment 10 Michael Burman 2018-05-02 07:27:09 UTC
Thanks, i will suggest to add this the the admin guide.


Note You need to log in before you can comment on or make changes to this bug.