Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154644 - 'strace64 date' segfaults
Summary: 'strace64 date' segfaults
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: strace
Version: 4.0
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Roland McGrath
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-13 10:12 UTC by Jay Turner
Modified: 2015-01-08 00:09 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-12 10:21:08 UTC


Attachments (Terms of Use)
'strace64 strace64 date' output (deleted)
2005-04-13 10:12 UTC, Jay Turner
no flags Details

Description Jay Turner 2005-04-13 10:12:13 UTC
Description of problem:
With both 4.5.8-1 and 4.5.9-2.EL4 I'm seeing 'strace64 date' segfault.  'strace
date' completes successfully.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jay Turner 2005-04-13 10:12:13 UTC
Created attachment 113086 [details]
'strace64 strace64 date' output

Comment 2 Roland McGrath 2005-04-21 20:54:26 UTC
Has this ever worked?  date is a 32-bit binary, right?

Comment 3 Jay Turner 2005-04-25 08:03:53 UTC
Yes, 'date' is a 32-bit binary:

# file `which date`
/bin/date: ELF 32-bit MSB executable, PowerPC or cisco 4500, version 1 (SYSV),
for GNU/Linux 2.2.5, dynamically linked (uses shared libs), stripped

I labelled it 'not a regression' during testing, so I'm not sure that it's ever
worked, but maybe something to look into.

Comment 4 Dmitry V. Levin 2006-01-06 23:01:17 UTC
It looks like another illustration for the problem I described in RH#173050.

Comment 5 Roland McGrath 2006-01-12 10:21:08 UTC
ppc32 strace does not handle ppc64 binaries and ppc64 strace does not handle
ppc32 binaries.  That's why there is an strace64 rpm on ppc64, so you can use
strace64 for 64-bit binaries and strace for 32-bit binaries.


Note You need to log in before you can comment on or make changes to this bug.