Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154642 - Yum cron ( /etc/cron.daily/yum.cron ) service is disabled after a reboot
Summary: Yum cron ( /etc/cron.daily/yum.cron ) service is disabled after a reboot
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-13 09:53 UTC by Adrian
Modified: 2014-01-21 22:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-13 12:56:28 UTC


Attachments (Terms of Use)

Description Adrian 2005-04-13 09:53:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.7.6) Gecko/20050323 Fedora/1.7.6-1.3.2

Description of problem:
If I enable (with "/etc/init.d/yum start") the yum cron (/etc/cron.daily/yum.cron), and then I restart the computer (reboot), the yum cron service is disabled. This is due to the file:

  /var/lock/subsys/yum

The file is used by the cron task to know if the service has been enabled. The file IS DELETED in the reboot, that is equivalent to stop the service:

  /etc/init.d/yum stop

So the yum cron is disabled by the reboot.


Version-Release number of selected component (if applicable):
yum-2.2.0-0.fc3

How reproducible:
Always

Steps to Reproduce:
1. Start the yum service: /etc/init.d/yum start
2. See that /var/lock/subsys/yum has been created.
3. Reboot the computer: reboot
4. See that /var/lock/subsys/yum has been deleted.
  

Actual Results:  Yum crom service won't be executed.

Expected Results:  Yum crom service should keep its state (enabled or disabled) after a reboot.

Additional info:

Probably all files in /var/lock/subsys are deleted in a reboot. So a solution would be to use other directory to store the file.

Comment 1 Adrian 2005-04-13 13:00:34 UTC
Sorry, I forgot the activation of the service:

  chkconfig yum on

Now the file is created every time the computer boots, so the yum cron works.



Note You need to log in before you can comment on or make changes to this bug.