Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154634 - [gcj]Saving as docbook xml fails with java.lang.IllegalAccessError: XSLTransformer$1
Summary: [gcj]Saving as docbook xml fails with java.lang.IllegalAccessError: XSLTransf...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-13 07:51 UTC by Mark Wielaard
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 1.9.99-2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-04 08:32:00 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNU Compiler Collection 19870 None None None Never

Description Mark Wielaard 2005-04-13 07:51:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050324 Galeon/1.3.20 (Debian package 1.3.20-1)

Description of problem:
Trying to save an text document as Docbook XML fails and gives the following output on the console:

Exception in thread "Thread-66" Reaped unknown child pid = 17562
Reaped unknown child pid = 17564
Reaped unknown child pid = 17566
Reaped unknown child pid = 17568
java.lang.IllegalAccessError: XSLTransformer$1: XSLTransformer.statsp
   at XSLTransformer$1.run() (Unknown Source)
   at .GC_start_routine (/usr/lib/libgcj.so.6.0.0)
   at .__clone (/lib/libc-2.3.4.so)


Version-Release number of selected component (if applicable):
1.9.92-1

How reproducible:
Always

Steps to Reproduce:
1. File -> New -> Text Document
2. Type some text
3. File -> Save
4. Browse for other folders
5. Select Docbook (.xml)
6. Save (Click yes on formatting dialog)
  

Actual Results:  Error dialog:
Error while saving document Untitled1:
Write error.
File could not be written.

And the output in the console described above:

Exception in thread "Thread-16" java.lang.IllegalAccessError: XSLTransformer$1: XSLTransformer.statsp
   at XSLTransformer$1.run() (Unknown Source)
   at .GC_start_routine (/usr/lib/libgcj.so.6.0.0)
   at .__clone (/lib/libc-2.3.4.so)


Expected Results:  Document should be saved as docbook xml.

Additional info:

This is with libgcj-4.0.0-0.40

Comment 1 Tom Tromey 2005-04-25 22:26:32 UTC
Where does XSLTransformer come from?  And how is it compiled?

Ordinarily this kind of problem is the result of a gcj bug.
In particular, "gcj -C" doesn't create accessor methods when there
are cross-class private member references (which is valid when the
two classes share a common top-level enclosing class).
Instead, gcj emits a direct reference, which the VM rejects.

One workaround is to compile with ecj instead.
Another is to make the private member package-private instead;
this is actually somewhat better since it avoids an accessor method.


Comment 2 Caolan McNamara 2005-04-27 12:13:47 UTC
That gives me some info to work with

Comment 3 Caolan McNamara 2005-05-03 11:04:17 UTC
caolanm->tromey: changing the accessor works. Is there an upstream gcj bug I can
cc myself to so to know when I can revert the patch I've added to work around this ?

Comment 4 Tom Tromey 2005-05-03 15:19:44 UTC
The upstream accessor bug is
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=19870



Note You need to log in before you can comment on or make changes to this bug.