Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154629 - "Assertion (heads < 256) at disk_dos.c:486 in function probe_partition_for_geom() failed." Error
Summary: "Assertion (heads < 256) at disk_dos.c:486 in function probe_partition_for_ge...
Keywords:
Status: CLOSED DUPLICATE of bug 138419
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-13 05:34 UTC by seb kaz
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-13 13:54:05 UTC


Attachments (Terms of Use)

Description seb kaz 2005-04-13 05:34:07 UTC
Description of problem:
I'm installing Fedora Core 3 onto my dads laptop. It origanaly had XP Pro 
(NTFS) with two other partitions on it,(Also NTFS) on the one 60GB HardDrive.
I deleted one of them to make room for FC3. I started the setup up and came up 
with 27 "Assertion (heads < 256) at disk_dos.c:486 in function 
probe_partition_for_geom() failed." errors.

So, it went on like that for a coupple of times and got realy annoing!

I read something on here about this and it didn't help! And my mum had a try.
Nothing.
And when I had another try, i did it with "noprobe". There was a Linux Swap 
partition configured for 13GB.
So I deleted that and made 6GB for FC3, and 2GB for the Swap.
And when I tried Saving the configuration, it through a hissy-fit at me with 
this error: Could not allocate requested partitions: Partitioning failed: Could 
not allocate partitions

So I tried again to see if it would make the partition. No.

So... I continued without the swap. Made XP the defult boot, No Firewall, USA 
English, Sydney Australia Location, Root Password: ****** (Taken out for 
security reasons) Custom packages for Personal PC, Began install, Got CD's #1, 
2 and 3

Then the bug came up: "Assertion (heads < 256) at disk_dos.c:486 in function 
probe_partition_for_geom() failed."
so I quit and came here for support

Version-Release number of selected component (if applicable):
Fedora Core 3 - anaconda

How reproducible:
Quite reproducible

Steps to Reproduce:
1.NTFS with Windows XP Pro
2.Partition for Fedora Core 3, 10GB
3.Start the setup
  
Actual results:
Massive errors. Failed Install result of loosing data

Expected results:
Errors reporting: "Assertion (heads < 256) at disk_dos.c:486 in function 
probe_partition_for_geom() failed."

Additional info:
None given

Comment 1 Chris Lumens 2005-04-13 13:54:05 UTC

*** This bug has been marked as a duplicate of 138419 ***


Note You need to log in before you can comment on or make changes to this bug.