Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154621 - "pnmtopgm" handles transparency incorrectly when working with colormapped PNG
Summary: "pnmtopgm" handles transparency incorrectly when working with colormapped PNG
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: netpbm
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-13 03:40 UTC by Robert Wilhite
Modified: 2013-07-02 23:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-14 15:11:48 UTC


Attachments (Terms of Use)

Description Robert Wilhite 2005-04-13 03:40:04 UTC
Description of problem:
"pnmtopgm" handles transparency incorrectly when working with colormapped PNG

Version-Release number of selected component (if applicable):
netpbm-10.25-2

How reproducible:
fails predictably

Steps to Reproduce:
1. grab a PNG from the pixmaps directory
2. convert it to PNM
3. reduce the colors below 256 to enable colormap handling
4. use pnmtopng with -transparent option, so for example...

pngtopnm /usr/share/pixmaps/gnomemeeting-splash.png | pnmdepth 10 | pnmtopng
-trans white > /tmp/test4.png
  
Actual results:
white region of picture is not transparent

Expected results:
white region of picture should be transparent

Additional info:
1. Worked fine in FC2.
2. Run that pipeline above about 20 times; it will occasionally seg-fault.
3. If you leave the "pnmdepth 10" step out, then pnmtopng doesn't try to create
a colormapped image, and the transparency works correctly.
4. This is my first time reporting a bug, so I hope I don't totally suck.

Comment 1 Jindrich Novy 2005-04-14 15:11:48 UTC
I tried that with netpbm-10.26.4 and netpbm-10.27 and I see it works now. So
upgrading to the latest devel netpbm should solve your problem.
(the white colour is transparent in the /tmp/test4.png image)

Jindrich


Note You need to log in before you can comment on or make changes to this bug.