Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154614 - installer completes but inittab missing
Summary: installer completes but inittab missing
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-13 01:47 UTC by Need Real Name
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-17 21:24:01 UTC


Attachments (Terms of Use)
Install logs for clean install that left me with no inittab (deleted)
2005-04-15 20:10 UTC, Barry Roberts
no flags Details

Description Need Real Name 2005-04-13 01:47:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
I ran the FC4test2 installer to completion, but at first boot significant portions of the system were missing.

INIT: version 2.85 booting
INIT: No inittab file found

Enter runlevel:

I entered "S" and mounted the filesystems.
I verified (rpm -qi SysVinit) that init was installed.

This system was a new installation on top of a previous FC3 install.

The /usr/local (/dev/vg00/local) and /home (/dev/vg00/home) filesystems were preserved.

The / (/dev/vg00/root), /var (/dev/vg00/var), /boot (/dev/hda5) and swap (/dev/hda6) partitions were initialized.

Also, I don't have an ifup command, and the only entry in /etc/sysconfig/network-scripts is ifcfg-eth0.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:

Comment 1 Jeremy Katz 2005-04-13 15:26:24 UTC
Can you provide /var/log/anaconda* and /root/install.log?

Comment 2 Need Real Name 2005-04-13 15:56:09 UTC
I've since re-installed the system so the logs are lost.  I'll need to determine
if I can wipe this system before trying to recreate it.

Comment 3 Barry Roberts 2005-04-15 20:10:01 UTC
Created attachment 113255 [details]
Install logs for clean install that left me with no inittab

I tried installing 3 times in a row, clean re-format each time.  Couldn't get a
successful install.  Tried without re-creating the software raid from scratch,
then without software raid.

Each time I entered:
linux askmethod reiserfs noselinux

at the boot prompt and did an NFS install from ISO's that have been sha1sum
--check'ed.

Comment 4 Barry Roberts 2005-04-17 17:23:05 UTC
I got the same thing at home (I'm blr@robertsr.us, that login is b0rked).

tried installing to ext3 and it worked.


Comment 5 Jeremy Katz 2005-04-17 21:24:01 UTC
Oh, you're using reiserfs.  reiserfs is *COMPLETELY UNSUPPORTED*

You'll probably need to boot with selinux=0 if you're going to use reiserfs.


Note You need to log in before you can comment on or make changes to this bug.