Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154610 - Debug messages during waking from sleep (acpi_pci_link_set calls kmem_cache_alloc with ints off)
Summary: Debug messages during waking from sleep (acpi_pci_link_set calls kmem_cache_a...
Keywords:
Status: CLOSED DUPLICATE of bug 154046
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-13 00:21 UTC by Brian G. Anderson
Modified: 2015-01-04 22:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-12-01 06:57:06 UTC


Attachments (Terms of Use)

Description Brian G. Anderson 2005-04-13 00:21:06 UTC
Description of problem:
I get the following debug message when waking my IBM Thinkpad T42p

Apr 12 17:12:18 bartali kernel: Stopping tasks:
=======================================================================================================================|
Apr 12 17:12:18 bartali kernel: Debug: sleeping function called from invalid
context at mm/slab.c:2096
Apr 12 17:12:18 bartali kernel: in_atomic():0, irqs_disabled():1
Apr 12 17:12:18 bartali kernel:  [<c015c3b4>] kmem_cache_alloc+0x63/0x78
Apr 12 17:12:18 bartali kernel:  [<c0247e4e>] acpi_pci_link_set+0x3f/0x17f
Apr 12 17:12:18 bartali kernel:  [<c0248298>] irqrouter_resume+0x14/0x28
Apr 12 17:12:18 bartali kernel:  [<c029144e>] sysdev_resume+0x3d/0xb5
Apr 12 17:12:18 bartali kernel:  [<c02956ed>] device_power_up+0x5/0xa
Apr 12 17:12:18 bartali kernel:  [<c014a7eb>] suspend_enter+0x44/0x46
Apr 12 17:12:18 bartali kernel:  [<c014a779>] suspend_prepare+0x57/0x85
Apr 12 17:12:18 bartali kernel:  [<c014a85e>] enter_state+0x49/0x54
Apr 12 17:12:18 bartali kernel:  [<c0245316>] acpi_system_write_sleep+0x5a/0x6c
Apr 12 17:12:18 bartali kernel:  [<c02452bc>] acpi_system_write_sleep+0x0/0x6c
Apr 12 17:12:18 bartali kernel:  [<c017bbc8>] vfs_write+0x9e/0x110
Apr 12 17:12:18 bartali kernel:  [<c017bce5>] sys_write+0x41/0x6a
Apr 12 17:12:18 bartali kernel:  [<c0103a61>] syscall_call+0x7/0xb
Apr 12 17:12:18 bartali kernel: hub 2-0:1.0: resubmit --> -108
Apr 12 17:12:18 bartali kernel: hub 3-0:1.0: resubmit --> -108
Apr 12 17:12:18 bartali kernel: hub 4-0:1.0: resubmit --> -108
Apr 12 17:12:18 bartali kernel: ehci_hcd 0000:00:1d.7: HC died; cleaning up
Apr 12 17:12:18 bartali kernel: ehci_hcd 0000:00:1d.7: USB 2.0 restarted, EHCI
1.00, driver 10 Dec 2004
Apr 12 17:12:18 bartali kernel: ACPI: PCI Interrupt 0000:00:1f.1[A] -> Link
[LNKC] -> GSI 11 (level, low) -> IRQ 11
Apr 12 17:12:18 bartali kernel: ACPI: PCI Interrupt 0000:00:1f.5[B] -> Link
[LNKB] -> GSI 11 (level, low) -> IRQ 11
Apr 12 17:12:18 bartali kernel: ACPI: PCI Interrupt 0000:00:1f.6[B] -> Link
[LNKB] -> GSI 11 (level, low) -> IRQ 11
Apr 12 17:12:18 bartali kernel: ACPI: PCI Interrupt 0000:02:01.0[A] -> Link
[LNKA] -> GSI 11 (level, low) -> IRQ 11
Apr 12 17:12:18 bartali kernel: ACPI: PCI Interrupt 0000:02:02.0[A] -> Link
[LNKC] -> GSI 11 (level, low) -> IRQ 11
Apr 12 17:12:18 bartali kernel: Restarting tasks... done
Apr 12 17:12:18 bartali gpm[4864]: *** info [mice.c(1766)]:
Apr 12 17:12:18 bartali gpm[4864]: imps2: Auto-detected intellimouse PS/2

Mostly the system works, but bluetooth has stopped working.  However, I don't
know if this message is related to that.  I've logged a seperate bug with the
bluetooth module in case it is a seperate problem.

Version-Release number of selected component (if applicable):
2.6.11-1.1236_FC4


How reproducible:
always on waking


Steps to Reproduce:
1. boot fedora on thinkpad t42p (set boot parameter acpi_sleep=s3_bios)
2. echo 3 > /proc/acpi/sleep
3. wake the computer
  
Actual results:
debug message


Expected results:
no debug message

Additional info:

Comment 1 Dave Jones 2005-12-01 06:57:06 UTC

*** This bug has been marked as a duplicate of 154046 ***


Note You need to log in before you can comment on or make changes to this bug.