Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154585 - Fedora fails to write grub.conf properly,Windows will not boot after installation
Summary: Fedora fails to write grub.conf properly,Windows will not boot after installa...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Mike McLean
URL:
Whiteboard: FC4
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-12 20:16 UTC by Marco
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-24 22:49:34 UTC


Attachments (Terms of Use)
Anaconda log (deleted)
2005-04-12 20:18 UTC, Marco
no flags Details
/boot/grub/device.map (deleted)
2005-04-12 20:19 UTC, Marco
no flags Details
buggy grub.conf created after installation (deleted)
2005-04-12 20:21 UTC, Marco
no flags Details

Description Marco 2005-04-12 20:16:27 UTC
Description of problem:
I've 2 hdd:
1st: is a SATA with one ntfs windows partition and some linux partitions (where
FC4T2 stay)
2nd: is a PATA with a fat32 partition (only storage data here, no OS at all)

I've done a clean FC4-T2 x86_64 install and when boot manager conf arrives, I've
choose to install GRUB to /dev/sda MBR (yes the 1st hdd, the SATA one).
The only one thing that I have changed is the driveorder FROM hda,sda TO sda,hda
I haven't touched the automatical recognized Windows partition.

When I rebooted after the installation Linux boot ok.
When I tried to boot Windows no OS is loaded, so I've entered Linux again,
edited my /etc/grub.conf and seen:
title Windows
   rootnoverify (hd1,0)
   chainloader +1

hd1 is mapped to PATA, so I changed to (hd0,0) and all works fine. 

Version-Release number of selected component (if applicable):
Fedora Core 4 test 2

How reproducible:
should have 2 hdd (in my case):
1st with a ntfs partition and windows installed and another partition with Linux
installed
2nd with a fat32 partition and NO OS installed

Install Fedora Core 4 test 2 from DVD
When grub conf prompts change the order of the hard disk to put SATA (/dev/sda)
the first one and choose to install grub to the /dev/sda MBR

Actual results:
At first reboot try to boot Windows and will not boot until you change manually
grub.conf

Expected results:
Windows boot normally without manually change grub.conf

Comment 1 Marco 2005-04-12 20:18:49 UTC
Created attachment 113053 [details]
Anaconda log

Comment 2 Marco 2005-04-12 20:19:48 UTC
Created attachment 113054 [details]
/boot/grub/device.map

Comment 3 Marco 2005-04-12 20:21:01 UTC
Created attachment 113055 [details]
buggy grub.conf created after installation

Comment 4 Henri Ala-Peijari 2005-05-05 17:21:54 UTC
I installed FC4test2 on a 3 partition drive with FC3-release,swap and the
partition for FC4test2. I didn't touch the defaults for grub-config part of
anaconda and I got a grub which only boots FC4test2. I thought all partitions
with and OS would be included automatically. A bug or policy?

Comment 5 Marco 2005-05-11 17:39:02 UTC
Bug still present in Fedora Core 4 test3.

Another small bug is that I have changed the name of the linux entry during
installation, and at the end of the installation I have discovered that Anaconda
changed to Linux (version of the kernel) that I don't want.

But of course the main bug is the most important.

Comment 6 Peter Jones 2005-05-24 22:49:34 UTC
I've replicated your scenario, and I don't think it is actually a bug.  Changing
the "drive order" merely changes which disk anaconda thinks the BIOS will boot
off of, and thus to which disk we'll install a boot loader.

There's no way to know which of your other partitions have an OS installed --
that's why there's a screen to edit our guess!

Comment 7 Marco 2005-05-24 23:16:10 UTC
Sorry I haven't understood why it isn't a bug.
I change the drive order ok, but I put sda as the hard disk that will have the
grub installed into its MBR, why anaconda thinks that the other hard disk will
contain another OS?

This bug is for me more serious when I have a correct grub.conf and anaconda
change it in a buggy one!

Comment 8 Marco 2005-05-26 09:12:18 UTC
I've added this bug more than one month ago and none take care about it, just
one day after absolute devel freeze closed as "NOT A BUG" this is very strange
and seems to be a "closing all blocking bugs" also without fix them and without
a clear explanation...

Comment 9 Marco 2005-10-19 12:44:44 UTC
As I said this IS a bug and fedora just don't want to fix.
I tried Kubuntu 5.10: same hardware, same hard disks, same partitions, same GRUB
v0.95 and Kubuntu was able to detect windows xp sp2 and write a fully functional
grub.conf


Note You need to log in before you can comment on or make changes to this bug.