Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154580 - Automatic Provides/Requires Mismatch
Summary: Automatic Provides/Requires Mismatch
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-12 19:58 UTC by Michael Jennings (KainX)
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-25 22:04:12 UTC


Attachments (Terms of Use)
Spec file (deleted)
2005-04-12 19:58 UTC, Michael Jennings (KainX)
no flags Details

Description Michael Jennings (KainX) 2005-04-12 19:58:36 UTC
Description of problem:

rpm 4.4.1 refuses to install/upgrade a package because the shared library
dependencies it auto-generated do not match.

Version-Release number of selected component (if applicable):

rpm-4.4.1-1

How reproducible:

Always.

Steps to Reproduce:
1.  Build acroread SRPM.  (Spec file attached, source tarball at
http://ardownload.adobe.com/pub/adobe/reader/unix/7x/7.0/enu/AdbeRdr70_linux_enu.tar.gz)
2.  Try to install it.
3.  File bug.  ;-)
  
Actual results:

# rpm -Uvh acroread-7.0-1.caos.i386.rpm
error: Failed dependencies:
        libACE.so is needed by acroread-7.0-1.caos.i386
        libACE.so(VERSION) is needed by acroread-7.0-1.caos.i386
        libAGM.so is needed by acroread-7.0-1.caos.i386
        libAGM.so(VERSION) is needed by acroread-7.0-1.caos.i386
        libBIB.so is needed by acroread-7.0-1.caos.i386
        libBIB.so(VERSION) is needed by acroread-7.0-1.caos.i386
        libCoolType.so is needed by acroread-7.0-1.caos.i386
        libCoolType.so(VERSION) is needed by acroread-7.0-1.caos.i386
        libResAccess.so is needed by acroread-7.0-1.caos.i386
# rpm -q --provides -p acroread-7.0-1.caos.i386.rpm
...skip...
libACE.so.2.07  
libACE.so.2.07(VERSION)  
libAGM.so.4.14  
libAGM.so.4.14(VERSION)  
libAXE16SharedExpat.so  
libAXE16SharedExpat.so(VERSION)  
libAXE8SharedExpat.so  
libAXE8SharedExpat.so(VERSION)  
libAXSLE.so  
libAXSLE.so(VERSION)  
libBIB.so.1.1  
libBIB.so.1.1(VERSION)  
libCoolType.so.5.01  
libCoolType.so.5.01(VERSION)  
...

Note the full SO version in the provides but not the requires.

Expected results:

Package should install properly.

Comment 1 Michael Jennings (KainX) 2005-04-12 19:58:36 UTC
Created attachment 113051 [details]
Spec file

Comment 2 Jeff Johnson 2005-10-25 22:04:12 UTC
This is because the DSO does not contain a DT_SONAME, and relies on 5 year old
fallback behavior that cannot be correctly inferred by the automagic elf dependency extractor
in rpm.

The right thing to do is to add a DT_SONAME to the DSO, but since this is acroread, well, disable
the internal dependency generator, or otherwise generate the dependencies
manually.


Note You need to log in before you can comment on or make changes to this bug.