Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154561 - mdadm can't handle >2TB array members
Summary: mdadm can't handle >2TB array members
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: mdadm
Version: 4.0
Hardware: i386
OS: Linux
Target Milestone: ---
: ---
Assignee: Doug Ledford
QA Contact:
Depends On:
TreeView+ depends on / blocked
Reported: 2005-04-12 17:57 UTC by Joshua Baker-LePain
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version: RHBA-2007-0290
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2007-05-01 17:46:24 UTC
Target Upstream Version:

Attachments (Terms of Use)

System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0290 normal SHIPPED_LIVE mdadm bug fix update 2007-05-01 17:45:47 UTC

Description Joshua Baker-LePain 2005-04-12 17:57:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

Description of problem:
My system has 2 3ware 9500-12 boards in it, each presenting the OS with a ~3TB disk.  I tried to assembe these into a RAID0 stripe, and:

[jlb@$HOST ~]$ sudo mdadm -C /dev/md0 -c 4096 -l 0 -n 2 /dev/sda4 /dev/sdb4
mdadm: Cannot get size of /dev/sda4: File too large
mdadm: Cannot get size of /dev/sdb4: File too large
mdadm: create aborted

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. sudo mdadm -C /dev/md0 -c 4096 -l 0 -n 2 /dev/sda4 /dev/sdb4

Actual Results:  It failed.

Expected Results:  It should create and start the array.

Additional info:

I installed mdadm-1.11.0 from and it worked just fine.

Comment 1 Doug Ledford 2007-01-31 18:56:52 UTC
We are upgrading mdadm from 1.6.0 to 1.12.0 in RHEL4.5, so this problem should
be solved by default.  I can't personally test it though due to lack of any
devices > 2TB in size.  However, I'll mark this bug as MODIFIED by the update so
QE can verify your results that it should work (and from code inspection is
should work as well, the new code in 1.12.0 uses an unsigned long long to hold
the device size and only falls back to unsigned long if FBLKGETSIZE64 isn't
available, so as long as the 64bit size syscall is available, mdadm should
support >2TB partitions).

Comment 2 Jay Turner 2007-01-31 22:01:58 UTC
QE ack for RHEL4.5.  Will need some testing directives on the mdadm rebase.

Comment 7 Red Hat Bugzilla 2007-05-01 17:46:24 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.