Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 15455 - dmesg messges
Summary: dmesg messges
Keywords:
Status: CLOSED DUPLICATE of bug 6006
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: magicdev
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-05 02:39 UTC by mal
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-08-05 21:26:52 UTC


Attachments (Terms of Use)

Description mal 2000-08-05 02:39:32 UTC
As soon as Gnome started it starts polluting dmesg 
buffer.
Use any IDE workstation and while 
no CD is in CDROM you get a new message 

VFS: Disk change detected on device ide1(22,0)
VFS: Disk change detected on device ide1(22,0)
VFS: Disk change detected on device ide1(22,0)
VFS: Disk change detected on device ide1(22,0)

about every two seconds.
Use dmesg and you will see these messages.
When you put a CD to CDROM 
the message of above stops and you get

VFS: Disk change detected on device ide1(22,0)
ISO 9660 Extensions: Microsoft Joliet Level 1
ISO 9660 Extensions: RRIP_1991A

no dmesg buffer polluting any more.
The problem problem exists only when 
no CD is in the CDROM when GNOME is running.

use dmesg command to see messages of above.

Comment 1 Alan Cox 2000-08-05 21:18:09 UTC
This is magicdev. Turning it off is one cure (it just automounts cds in gnome).
Reassigned


Comment 2 Owen Taylor 2000-08-05 21:42:15 UTC
I don't know of a way of fixing this within magicdev. See Bug #6006
for extensive commentary. (Until someone tells me a good reason for the
printk(), I would consider it a kernel misfeature that it is printing
out these messsages, leaving aside the misdetection of media changes.)

*** This bug has been marked as a duplicate of 6006 ***


Note You need to log in before you can comment on or make changes to this bug.