Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154544 - Intermittent X Window System error
Summary: Intermittent X Window System error
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: redhat-config-cluster
Version: 4
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jim Parsons
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-12 15:32 UTC by Paul Kennedy
Modified: 2015-04-20 00:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-09 21:38:13 UTC


Attachments (Terms of Use)

Description Paul Kennedy 2005-04-12 15:32:56 UTC
Description of problem:
Starting system-config-cluster causes an X Window System error; however the
error occurs intermittently.

Version-Release number of selected component (if applicable):
0.9.26 

How reproducible:
Run system-config-cluster and observe error message. Refer to "Actual Result".
When the error occurs, the GUI window is displayed very briefly, then closes. 

  
Actual results:
[root@tng3-4 root]# system-config-cluster
The program 'system-config-cluster' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAccess (attempt to access private resource denied)'.
  (Details: serial 317 error_code 10 request_code 147 minor_code 5)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)


Expected results:
GUI window stays open and no error messages occur. 

Additional info:
This problem occurs *very* rarely. I tried to reproduce the problem over 120
times, but with no error.

Comment 1 Jim Parsons 2005-05-09 21:38:13 UTC
I have yet to see this bug happen. I have spoken to the X gurus here, and they
say that it looks like a video card driver issue. I have also ran down what the
request_code 147 is for, and it is an obscure extension error code for a stale
buffer when doing remote display. Closing this bug for the time being -- until
someone experiences it again and i can try attaching a debugger to the thing.


Note You need to log in before you can comment on or make changes to this bug.