Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154505 - Segmentation fault in initstate_r () from /lib/tls/libc.so.6
Summary: Segmentation fault in initstate_r () from /lib/tls/libc.so.6
Keywords:
Status: CLOSED DUPLICATE of bug 154504
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: 3
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
: 154506 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-12 10:12 UTC by Mateusz Ploskon
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-12 10:51:43 UTC


Attachments (Terms of Use)

Description Mateusz Ploskon 2005-04-12 10:12:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux) (KHTML, like Gecko)

Description of problem:
// following code compiled with 
// gcc -g -O3 -ansi -pedantic -save-temps test.c 
// causes: 
// Program received signal SIGSEGV, Segmentation fault. 
// 0x0040d130 in initstate_r () from /lib/tls/libc.so.6 
 
#include<stdio.h> 
#include<string.h> 
 
int main() 
{ 
  char s[255]; 
  sprintf(s, "%s", "ala ma kota"); 
 
  strfry(s); 
  return 0; 
} 
 

Version-Release number of selected component (if applicable):
libc-2.3.5.so

How reproducible:
Always

Steps to Reproduce:
1.compile the description 
2.run a.out 
3. 
   

Additional info:

> gcc -v 
Reading specs from /usr/lib/gcc/i386-redhat-linux/3.4.2/specs 
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man 
--infodir=/usr/share/info --enable-shared --enable-threads=posix 
--disable-checking --with-system-zlib --enable-__cxa_atexit 
--disable-libunwind-exceptions --enable-java-awt=gtk --host=i386-redhat-linux 
Thread model: posix 
gcc version 3.4.2 20041017 (Red Hat 3.4.2-6.fc3)

Comment 1 Mateusz Ploskon 2005-04-12 10:17:36 UTC
*** Bug 154506 has been marked as a duplicate of this bug. ***

Comment 2 Mateusz Ploskon 2005-04-12 10:51:43 UTC

*** This bug has been marked as a duplicate of 154504 ***


Note You need to log in before you can comment on or make changes to this bug.