Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154500 - system-config-printer-gui spits out traceback when editing settings for existing printer
Summary: system-config-printer-gui spits out traceback when editing settings for exist...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
: 152592 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-12 08:48 UTC by Dennis Wagelaar
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 0.6.129-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-12 11:19:10 UTC


Attachments (Terms of Use)
'printconf-tui --Xexport' output (deleted)
2005-04-12 11:51 UTC, Dennis Wagelaar
no flags Details
printconf-tui --Xexport (deleted)
2005-04-12 11:56 UTC, Rick Richardson
no flags Details

Description Dennis Wagelaar 2005-04-12 08:48:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
When trying to add a description for an existing printer (added via wizard) in system-config-printer (gui version), the application spits out a traceback and the "Edit a print queue" window becomes unresponsive. Here's the traceback that I got:

Traceback (most recent call last):
  File "/usr/share/printconf/util/queueTree.py", line 600, in edit_button_clicked
    if self.editQueue.editQueueDialog (iter):
  File "/usr/share/printconf/util/editQueue.py", line 452, in editQueueDialog
    self.read_driver_options ()
  File "/usr/share/printconf/util/editQueue.py", line 1015, in read_driver_options
    dict[key] = store.get_value (iter, 1)
TypeError: iter must be a GtkTreeIter

Version-Release number of selected component (if applicable):
system-config-printer-0.6.116.1.4-1

How reproducible:
Always

Steps to Reproduce:
1. run 'system-config-printer' from the command line
2. choose a printer and click "Edit"
3. enter a "Short description" and click "OK"
  

Actual Results:  Window becomes unresponsive (widgets no longer work, window only closes via window manager) and the app spits out a Traceback.

Expected Results:  Windows should close and printer settings should have been updated.

Additional info:

Comment 1 Tim Waugh 2005-04-12 11:36:19 UTC
I don't see this.

Please attach the output of 'printconf-tui --Xexport', and indicate which
printer it is that you click on in the above 'steps to reproduce'.

Comment 2 Tim Waugh 2005-04-12 11:36:48 UTC
*** Bug 152592 has been marked as a duplicate of this bug. ***

Comment 3 Dennis Wagelaar 2005-04-12 11:51:49 UTC
Created attachment 113016 [details]
'printconf-tui --Xexport' output

I've attached the output of 'printconf-tui --Xexport'. The printer I've been
trying to edit is SSELHPLJ. I don't know if this matters, but I'm using
'system-config-printer' remotely through 'ssh -Y' (it's the config on our print
server).

Comment 4 Rick Richardson 2005-04-12 11:56:29 UTC
Created attachment 113017 [details]
printconf-tui --Xexport

Comment 5 Tim Waugh 2005-04-12 12:25:29 UTC
Fixed in CVS.  Thanks for the report.

Comment 6 Michal Jaegermann 2005-05-07 18:12:32 UTC
The same bug hits when trying to configure a printer with most of an "Epson"
list.  At least when trying to use "omni-compiled" driver.


Note You need to log in before you can comment on or make changes to this bug.