Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154480 - ppc nfs install fails says "this directory does not appear to contain a Fedora Core installation tree"
Summary: ppc nfs install fails says "this directory does not appear to contain a Fedor...
Keywords:
Status: CLOSED DUPLICATE of bug 150887
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda-images
Version: 4
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-12 04:24 UTC by Clinton Goudie-Nice
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-12 15:25:53 UTC


Attachments (Terms of Use)

Description Clinton Goudie-Nice 2005-04-12 04:24:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322)

Description of problem:
When trying to do an nfs install of FC4-test1-ppc on an imac 333, I get the following error:
this directory does not appear to contain a Fedora Core installation tree

In looking at the other ttys I can see that it mounted my nfs directory on /mnt/source
then the lines go like this:
unable to access /mnt/source/Fedore/base/stage2.img
mntloop loop7 on /tmp/loopimage as /mnt/source/FC4-test1-ppc-disc1.iso fd is 27
mntloop loop0 on /mnt/runtime as /tmp/loopimage/Fedora/base/fdstg2.img fd is 27
unmounting loopback /tmp/runtime loop0 
LOOP_CLR_FD failed for /tmp/runtime loop0 (Device or resource busy)
unmounting loopback /tmp/loopimage loop7
LOOP_CLR_FD failed for /tmp/loopimage loop7 (Device or resource busy)
Path to balid iso is /mnt/source/FC4-test1-ppc-disc1.iso 
mntloop loop1 on /mnt/source2 as /mnt/source/FC4-test1-ppc-disc1.iso fd is 26
mntloop loop0 on /mnt/runtime as /tmp/loopimage/Fedora/base/stage2.img fd is 26
LOOP_SET_FD failed: Device or resource busy
unmounting loopback /tmp/source2 loop1

The directory contains all the binary ISOs and the SHA1SUM file

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Begin an nfs install on the ppc
2. nfs install fails to start with the error specified.
3.
  

Additional info:

Comment 1 Colin Charles 2005-04-12 07:55:01 UTC
Was this with an exploded tree, or just exported NFS of the ISOs? If it was the
latter, there was a bug that caused said issue. If it was an exploded tree (i.e.
your nfs mount had:

autorun     headers               RPM-GPG-KEY-beta
boot_image  images                RPM-GPG-KEY-fedora
etc         ppc                   RPM-GPG-KEY-fedora-rawhide
eula.txt    README-Accessibility  RPM-GPG-KEY-fedora-test
Fedora      repodata              RPM-GPG-KEY-rawhide
GPL         RPM-GPG-KEY           yumgroups.xml

) then this bug is new. 

Comment 2 Clinton Goudie-Nice 2005-04-12 14:30:50 UTC
It was just the ISOs. I'll give it a try tonight with the ISOs from test2.

Comment 3 Jeremy Katz 2005-04-12 15:25:53 UTC

*** This bug has been marked as a duplicate of 150887 ***


Note You need to log in before you can comment on or make changes to this bug.