Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154467 - kernel update was compiled with different gcc version
Summary: kernel update was compiled with different gcc version
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: 3
Hardware: i686
OS: Linux
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
Depends On:
TreeView+ depends on / blocked
Reported: 2005-04-12 00:21 UTC by Florin Andrei
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version: 3.4.3-22.fc3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2005-04-12 21:35:28 UTC

Attachments (Terms of Use)

Description Florin Andrei 2005-04-12 00:21:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
This kernel update appears to have been built with gcc-3.4.3, while the compiler currently available on FC3 is gcc-3.4.2
This causes problems with some applications that require additional kernel modules.
Please either release a gcc update, or a new kernel update that was compiled with the current gcc.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.see above

Additional info:

Comment 1 Warren Togami 2005-04-12 00:28:58 UTC
Have you *tried* kernel modules built with gcc-3.4.3 anyway?  They seem to work
for me in FC3 with these kernels.  Anyway, reassigning to gcc.  We'll let jakub

Comment 2 Florin Andrei 2005-04-12 00:51:12 UTC
I tried, it fails. There could be many reasons for the failure, true, and i
didn't look too closely (not that i'm a kernel modules expert anyway), but...
well, that's it.

Comment 3 Dave Jones 2005-04-12 00:55:46 UTC
gcc-3.4.3 is in updates-testing.

Comment 4 Matthew Miller 2005-04-12 03:22:16 UTC
FWIW, openafs seems to work fine (for the current definition of openafs working
fine) with the new kernel and gcc 3.4.2.

Comment 5 Warren Togami 2005-04-12 04:06:05 UTC
> for the current definition of openafs working fine


Note You need to log in before you can comment on or make changes to this bug.