Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154462 - sensors-detect gives bad advice;here's a little patch
Summary: sensors-detect gives bad advice;here's a little patch
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: lm_sensors
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-11 22:31 UTC by David Tonhofer
Modified: 2015-03-05 01:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-05-12 12:24:52 UTC


Attachments (Terms of Use)
Patch for sensors-detect (deleted)
2005-04-11 22:35 UTC, David Tonhofer
no flags Details | Diff

Description David Tonhofer 2005-04-11 22:31:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
Running sensors-detect manually gives confusing/bad advice. I might be
advantageous to modify the script slightly regarding file names and explanations
given. As I don't know what the setup on distros other than Red Hat is, this
is a stab in the dark, but here goes.

Modifications:

The script does not check for '/etc/modprobe.conf' which seems to be standard
under 2.6 but uses only 'old style' names - added.

The advice given to the user to modify the boot init script is unnecessary -
the /etc/sysconfig/lm_sensors file contains the list of modules already. 
Fixed but only if the script finds it's on a Red Hat system. Also:
sensors -s may have to be added manually. Tell the user.

Note that the Red Hat system is detected by checking for /etc/redhat-release.

Additional explanations regarding /etc/sysconfig/lm_sensors given. Also
a warning saying that some modules might not yet have been ported to 2.6!

Use variables for location of boot script and lm_sensors file. The script
seems to assume that the boot script is always /etc/rc.d/init.d/lm_sensors.
Which might be incorrect, but that's what it did originally. 

Putting a GNU copyleft header into /etc/sysconfig/lm_sensors strikes me
as serious overkill. Removed. Yes, I'm arrogant.

Advice to user to copy boot script suppressed on Red Hat systems.









Version-Release number of selected component (if applicable):
lm_sensors-2.8.7-2

How reproducible:
Always

Steps to Reproduce:
n/a 

Actual Results:  n/a

Expected Results:  n/a

Additional info:

n/a

Comment 1 David Tonhofer 2005-04-11 22:35:46 UTC
Created attachment 112999 [details]
Patch for sensors-detect

Comment 2 Phil Knirsch 2005-09-01 17:39:42 UTC
I like some parts of the patch, but with 2.9.1 which we now have in FC4 and
later most of the kernel-2.6 issues should be handled properly.

I might put in a trimmed down version of this patch in a later version.

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.