Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154386 - Emacs will not have the DTD drop down menu until psgml package is installed
Summary: Emacs will not have the DTD drop down menu until psgml package is installed
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora Documentation
Classification: Fedora
Component: docs-requests
Version: devel
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Wade
QA Contact: Mark Johnson
URL: http://fedora.redhat.com/participate/...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-11 10:41 UTC by Michael Kearey
Modified: 2009-07-07 04:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-19 02:14:02 UTC


Attachments (Terms of Use)
Include brief narrative indicating that PSGML requires psgml RPM (deleted)
2005-04-11 14:31 UTC, Paul W. Frields
no flags Details | Diff

Description Michael Kearey 2005-04-11 10:41:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050322 Firefox/1.0.2 Red Hat/1.0.2-1.4.1

Description of problem:
Following the the Documentation Guide, I found a small omission.

The psgml package should be in the list of required packages. Alternatively since using Emacs is optional, perhaps mention in the section http://fedora.redhat.com/participate/documentation-guide/s1-emacs-cedfile.html somewhere that you need the psgml package installed.

Without it Emacs has no DTD drop down menu. 

Version-Release number of selected component (if applicable):
Fedora Project Documentation Guide Version 0.2.5

How reproducible:
Always

Steps to Reproduce:
1. Read Fedora Project Documentation Guide Version 0.2.5
2. Get to the section 3.3. Create Recompiled DTD Subset
3. Without psgml installed, the DTD menu item is not available
  

Actual Results:  No DTD menu. Confusion, posibly stop using Emacs.

Expected Results:  Emacs started, and displays the DTD menu as described in 3.3. Create Recompiled DTD Subset

Additional info:

Comment 1 Paul W. Frields 2005-04-11 14:31:23 UTC
Created attachment 112947 [details]
Include brief narrative indicating that PSGML requires psgml RPM

I took the liberty of doing this since I had a couple minutes free.  I agree
the Docs Guide might benefit from some revisitation some day "Real Soon Now." 
I have another bug I'll be entering regarding a recent run-in with SGML vs. XML
DTD parsing.  Patch will be included!  :-)

Comment 2 eric@christensenplace.us 2009-07-07 04:08:51 UTC
Ticket moved to allow products to be removed from BZ.


Note You need to log in before you can comment on or make changes to this bug.