Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154379 - when firstboot begins, give error message
Summary: when firstboot begins, give error message
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: firstboot
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Chris Lumens
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-11 08:34 UTC by ethan gunword
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-23 14:58:43 UTC


Attachments (Terms of Use)

Description ethan gunword 2005-04-11 08:34:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050324 Firefox/1.0.2 Red Hat/1.0.2-1.4.1

Description of problem:
Traceback (most recent call last):
  File "/usr/share/firstboot/firstbootWindow.py", line 502, in loadModules
    vbox, pix, title = module.launch()
  File "/usr/share/firstboot/modules/display.py", line 81, in launch
    self.setupScreen()
  File "/usr/share/firstboot/modules/display.py", line 60, in setupScreen
    self.displayClass = xConfigDialog.XConfigDialog(hardware_state, xconfig, vc)
  File "/usr/share/system-config-display/xConfigDialog.py", line 558, in __init__
    if len(self.xconfig.layout[0].adjacencies) > 1:
AttributeError: 'NoneType' object has no attribute 'layout'


Since there is a problem with the Display module, 
Gelecek Setup Agent will not load this module and 
will attempt to run the remaining modules.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.firstboot --reconfig
2.
3.
  

Additional info:

Comment 1 Chris Lumens 2005-07-18 17:58:58 UTC
What video hardware do you have in this computer?  Can you start up X at all?

Comment 2 Chris Lumens 2005-09-23 14:58:43 UTC
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received the feedback we
requested, we will assume the problem was not reproduceable or has been fixed in
a later update for this product.  If you have further details, feel free to
reopen the report with the additional details attached.


Note You need to log in before you can comment on or make changes to this bug.