Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154368 - Clicking in pre-filled form text-entry boxes doesn't place the cursor in the correct location.
Summary: Clicking in pre-filled form text-entry boxes doesn't place the cursor in the ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-11 07:28 UTC by Stephen Warren
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-01 15:13:40 UTC


Attachments (Terms of Use)

Description Stephen Warren 2005-04-11 07:28:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
Clicking in pre-filled form text-entry boxes doesn't place the cursor in the correct location.

Version-Release number of selected component (if applicable):
firefox-1.0.2-1.3.1

How reproducible:
Always

Steps to Reproduce:
1. Enter a new bug at bugzilla.redhat.com using the guided steps.
2. At the main page where you fill in description, steps to reproduce, etc., left-click in the pre-filled "Steps to Reproduce" text box (3 lines are present which are prefilled "1.", "2.", and "3.") Click on the very first line, after all text in that line.


Actual Results:  The cursor/caret is position prior to the very first character on line 1, despite clicking after all text on line 1. Clicking again does not move the cursor to the correct location.

Expected Results:  The cursor/caret should be positioned where the mouse is clicked. Since the mouse was clicked to the right of the text on line 1, any typing one performs should be appended to line 1, not pre-pended (i.e. the cursor/caret should be placed at the end of the line, not the start).

Additional info:

Attempting the same test on lines 2 or 3, or in the middle of any line (e.g. between the "1" and the "." on line 1) also incorrectly positions the cursor/caret.

After some amount of editing, the cursor will be correctly positioned when the mouse is clicked.

Comment 1 Stephen Warren 2005-04-11 07:29:46 UTC
After the cursor/caret has been incorrectly positioned, pressing the END key on
the keyboard won't move the cursor/caret to the end of the line. Instead, the
RIGHT cursor key must be used. Once the cursor/caret is at the end of the line,
pressing the END key will move the cursor/caret back to the beginning of the line.

Comment 2 Warren Togami 2005-09-30 19:45:39 UTC
Is this still an issue with the latest FC updates?

If so, can you reproduce the same bad behavior with MOZ_DISABLE_PANGO=1?


Comment 3 Stephen Warren 2005-09-30 20:54:53 UTC
Do you mean the lastest "yum update"'d FC3, or something like the latest dev
releases?

Comment 4 Stephen Warren 2005-10-01 07:27:51 UTC
With firefox-1.0.7-1.1.fc3 installed, I cannot reproduce the bug (I did not need
to set MOZ_DISABLE_PANGO=1).

I tested:
* Clicking at start/middle/end of each line in the text box
* Home/End keys
* Ctrl-Home/End keys
* Cursoring around
* Ctrl-Cursoring around (word jump)

All this worked correctly.

Thanks.



Note You need to log in before you can comment on or make changes to this bug.