Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154362 - Preedit hidden after choosing the candidate
Summary: Preedit hidden after choosing the candidate
Keywords:
Status: CLOSED DUPLICATE of bug 154360
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-data-server
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC4Blocker 157397
TreeView+ depends on / blocked
 
Reported: 2005-04-11 06:05 UTC by Leon Ho
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-23 23:32:36 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 303874 None None None Never

Description Leon Ho 2005-04-11 06:05:25 UTC
Description of problem:
Preedit is hidden after choosing the candidate in cannaLE candidate window

Version-Release number of selected component (if applicable):
evolution-2.2.1.1-2
evolution-data-server-1.2.1-1
iiimf-le-canna-12.1.1-11.svn2435

How reproducible:
everytime

Steps to Reproduce:
1. LANG=ja_JP.UTF-8 evolution
2. Go to task list
3. Go to new task entry in the widget
4. Type "sushi", space, space 
5. In candidate window, press enter to select the candidate
  
Actual results:
preedit is hidden

Expected results:
preedit should be shown

Additional info:
continue to type again will re-show the preedit string.

Comment 1 Lawrence Lim 2005-05-11 07:05:33 UTC
There is a second part to this bug.

Actual results:
preedit is hidden and the selected candidates are not committed

Expected results:
preedit buffer should be destroyed and selected candidates gets committed

Additional info:
continue to type again will re-show the preedit string.


Tested with the following packages in FC.
evolution-webcal-2.2.0-1
evolution-2.2.2-5
evolution-data-server-1.2.2-2
evolution-devel-2.2.2-5
evolution-data-server-devel-1.2.2-2
evolution-connector-2.2.2-3
evolution-debuginfo-2.2.2-5



Comment 2 Akira TAGOH 2005-05-18 03:23:23 UTC
This problem goes away after applying two patches I attached for #154360.

Comment 3 Lawrence Lim 2005-05-20 08:20:33 UTC
Tested with test packages with patch from Comment #2, confirm that this bug has
been resolved with the patch.

Thanks.


Comment 4 Jeremy Katz 2005-05-23 23:32:36 UTC

*** This bug has been marked as a duplicate of 154360 ***

Comment 5 Lawrence Lim 2005-05-26 06:55:29 UTC
Confirmed fixed with evolution-2.2.2-7 and libgal2-2.4.2-5 in dist fc4-hold.




Note You need to log in before you can comment on or make changes to this bug.