Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154350 - Loading file from archive fails if filename contains spaces
Summary: Loading file from archive fails if filename contains spaces
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: file-roller
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-10 19:53 UTC by Need Real Name
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-20 18:37:55 UTC


Attachments (Terms of Use)
Example of failure (deleted)
2005-10-19 12:54 UTC, Need Real Name
no flags Details

Description Need Real Name 2005-04-10 19:53:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050322 Epiphany/1.5.8

Description of problem:
Create a file called test.doc, and create a .zip archive using file-roller.
Open the archive, and double-click the file. OpenOffice launches.

Now rename test.doc in the archive to test with spaces.doc.
Open the archive, and double-click the file. OpenOffice cannot find it - the correct filename (although with escaped spaces) is shown in the error dialog.

Now add a pdf file with spaces. evince complains "cannot determine mime type".
I *think* this error message is wrong. It can't find the file either.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:

Comment 1 Robin Green 2005-05-04 16:45:50 UTC
The problem (at least in version file-roller-2.10.0-1, which is the one I'm
using) is that in window_open_files__extract_done_c the filename has already
been escaped (using shell-style escaping). But then that function calls
gnome_vfs_get_uri_from_local_path, which escapes the _escaped_ filename (using
URL-style escaping), which doesn't make sense. The filename should only be
escaped once.

Both of the functions I mentioned are in src/window.c.

This affects all files with escapable characters anywhere in their path, not
just files with spaces.

Comment 2 Need Real Name 2005-06-02 13:57:22 UTC
Great! I thought it sounded like an escaping bug. Hopefully this will make FC4.

Comment 3 Need Real Name 2005-07-01 20:07:52 UTC
Any chance of getting this fix in?

Comment 4 Need Real Name 2005-10-19 12:54:23 UTC
Created attachment 120159 [details]
Example of failure

Comment 5 Need Real Name 2006-01-20 21:06:09 UTC
WFM.

Comment 6 Rahul Sundaram 2006-02-20 11:09:16 UTC

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks

Comment 7 Need Real Name 2006-02-20 17:53:20 UTC
Yikes - why the reopen? It's fixed.

Comment 8 Christopher Aillon 2006-02-20 18:37:55 UTC
Closing.


Note You need to log in before you can comment on or make changes to this bug.