Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154349 - sundance network driver is missing in RHEL4 kernel
Summary: sundance network driver is missing in RHEL4 kernel
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.8
Hardware: All
OS: Linux
Target Milestone: ---
: ---
Assignee: Ivan Vecera
QA Contact: Brian Brock
Depends On:
Blocks: 461304
TreeView+ depends on / blocked
Reported: 2005-04-10 19:37 UTC by Bernd Bartmann
Modified: 2018-10-20 00:47 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2008-09-23 14:10:03 UTC
Target Upstream Version:

Attachments (Terms of Use)

Description Bernd Bartmann 2005-04-10 19:37:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
The sundance network driver is missing from the RHEL4 kernel. This driver is required for the DLINK DL10050 4-port network card.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. try: "modprobe sundance"

Additional info:

Comment 1 Rik van Riel 2005-04-10 22:20:20 UTC
Feature request, reassigning to management.

Comment 2 Bernd Bartmann 2005-04-11 05:30:45 UTC
Just out of curiosity are there any technical reasons to not include this driver
by default? BTW: The driver is included in RHEL3 in kernel-unsupported.

Comment 3 David Lawrence 2006-03-03 18:45:45 UTC
The bug status ASSIGN_TO_PM has been deprecated. In the future please use
ASSIGNED and either add the PM to the Cc list or re-assign report to them.

Comment 4 David Tonhofer 2006-12-17 22:51:16 UTC
Card is indeed not supported in Red Hat ES 4 2.6.9-42.0.3. Snif!

The correct name for this hardware is D-Link "DFE-580TX"

"lspci" shows the four controllers on the card:

02:04.0 Ethernet controller: D-Link System Inc DL10050 Sundance Ethernet (rev 15)
02:05.0 Ethernet controller: D-Link System Inc DL10050 Sundance Ethernet (rev 15)
02:06.0 Ethernet controller: D-Link System Inc DL10050 Sundance Ethernet (rev 15)
02:07.0 Ethernet controller: D-Link System Inc DL10050 Sundance Ethernet (rev 15)

Hardware cannot be found on the U.S. website for D-LINK, but can be found on the
European site (discontinued in the US?!)

D-Link downloads include a GPL-ed driver for Linux 2.4 called "dlh5x-1.10." 

The comment section says:

/* sundance.c: A Linux device driver for the Sundance ST201 "Alta". */
	Written 1999-2000 by Donald Becker.

Kinda old. Indeed needs support for Red Hat ES 4.0...

Comment 5 Bernd Bartmann 2007-03-24 17:17:59 UTC
There is still no support for this card neither in RHES 4U4 nor RHES5. Can
someone please explain why this card is not supported? This seems to be the only
available 4 port 100Base-TX PCI network card. So support in RHES for this card
is badly needed!

Comment 7 Rik van Riel 2008-04-02 13:53:16 UTC
Feature requests go through management.  Unfortunately riek seems to have
ignored the bug.  Luckily there's now a kernel-mgr address...

Comment 10 Daniel Riek 2008-08-27 19:47:36 UTC
This driver seems to be more or less unmaintained and I am having a hard time to find any place to buy this kind of card anymore. Is Dlink still offering it at all?

Comment 12 Bernd Bartmann 2008-08-27 20:33:17 UTC
Indeed, you can still get this card at several German internet shops like

Also, this driver has been enabled for RHES 5.2. So it is even in the latest RHES release.

Comment 13 RHEL Product and Program Management 2008-09-03 13:13:19 UTC
Updating PM score.

Comment 14 Daniel Riek 2008-09-23 13:58:30 UTC
Yes, we have the driver in RHEL5.

This and the late state of RHEL4 in it's life-cycle (extended hardware enablement), clearly is an argument against enabling it in RHEL4, as it has never before been supported in that version. 

Finally, looking at the overall content planned for RHEL 4.8, this is almost certainly not going to make it.

Comment 15 Peter Martuccelli 2008-09-23 14:06:23 UTC
Devel NAK for R4.8.

Comment 16 RHEL Product and Program Management 2008-09-23 14:10:03 UTC
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.