Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 154344 - Cleaning and rebuilding projects "just sits there."
Summary: Cleaning and rebuilding projects "just sits there."
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ben Konrath
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-10 15:08 UTC by Andrew Overholt
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-10-04 14:23:08 UTC


Attachments (Terms of Use)

Description Andrew Overholt 2005-04-10 15:08:25 UTC
Description of problem:
Cleaning and rebuilding projects "just sits there."

Version-Release number of selected component (if applicable):
eclipse-jdt-3.1.0_fc-0.M6.1

How reproducible:
Random.

Steps to Reproduce:
1. Attempt to clean and build all projects.
  
Actual results:
!ENTRY org.eclipse.core.resources 2 1 2005-04-10 10:43:41.205
!MESSAGE Skipping builder com.ibm.sse.model.structuredbuilder for project
java-gnome. Either the builder is missing from the install, or it belongs to a
project nature that is missing or disabled.

Expected results:
Nothing in the log and the projects should clean and re-build.

Additional info:
This is with the preview 3.1M6 RPMs.  During this time when the progress bar
wasn't moving, the memory usage seemed to remain constant, but the CPU usage was
fluctuating between high and quite high (say, 60 - 90%).  I'm wondering if this
is the same problem and bug 151832.

Comment 1 Jeff Pound 2005-04-28 19:16:00 UTC
Clean + build working as of: eclipse 3.1.0_fc-0.M6.12 and gcc-4.0.0-1

Comment 2 Ben Konrath 2005-05-10 18:43:58 UTC
This bug is still around but it only happens on slower machines. I can reproduce
it on my laptop.

I think that the warning noted in the original bug report is a problem with the
.project file from java-gnome.

Comment 3 Ben Konrath 2005-05-12 01:46:26 UTC
I think that is a miscompilation of org.eclipse.core.runtime_3.1.0.jar - when I
moved org.eclipse.core.runtime_3.1.0.jar.so out of the way, the problem stopped.

The test case is as follows:

(1) get a slow machine (my laptop is a 1.6Ghz P4 / 512Mb RAM)
(2) check out the following modules from various cvs repos:
     * jg-common
     * cairo-java
     * gst-java
     * libgtk-java
(3) Project -> Clean ... -> select "Clean all projects" radio -> OK

Eclipse will hang if org.eclipse.core.runtime_3.1.0.jar.so is being used. 

Andrew, what do you think about moving org.eclipse.core.runtime_3.1.0.jar.so out
of the way until we sort this out?

Comment 4 Ben Konrath 2005-05-13 16:00:44 UTC
I think that I jumped the gun a little here because I can reproduce the problem
when I move classmap.db out of the way so it's not a miscompilation. The problem
seems to be that it is *really* slow to build the workspace with those projects
checked out. Still investigating.

Comment 5 Nitin Dahyabhai 2005-08-18 20:20:31 UTC
Just as a FYI, the com.ibm.sse.model.structuredbuilder was used in Rational V6
products and in IBM's Initial Contribution to the Web Tools Platform project on
Eclipse.org.  Messages about it being missing are harmless as that builder was
only ever used to detect Tasks in the file types supported by WTP--it does
nothing critical.  That functionality's been replaced in the WTP 0.7 release.

Comment 6 Andrew Overholt 2006-02-09 16:25:38 UTC
(In reply to comment #5)
> Just as a FYI, the com.ibm.sse.model.structuredbuilder was used in Rational V6
> products and in IBM's Initial Contribution to the Web Tools Platform project on
> Eclipse.org.  Messages about it being missing are harmless as that builder was
> only ever used to detect Tasks in the file types supported by WTP--it does
> nothing critical.  That functionality's been replaced in the WTP 0.7 release.

Thanks for the info, Nitin.

Ben, if you get a chance, can you see if you can still duplicate this?  It
doesn't happen to me, FWIW.


Comment 7 Ben Konrath 2006-10-04 14:23:08 UTC
I can't duplicate this with 3.2.1-4, closing bug.


Note You need to log in before you can comment on or make changes to this bug.